YesWiki Vulnerable to Authenticated PHP Object Injection in BazarImportAction via unserialize
CVE-2026-52777GHSA-9369-69wj-7m2f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (yeswiki/yeswiki 4.6.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist yeswiki/yeswiki
- Affected
- < 4.6.6
- Fixed in
- 4.6.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9369-69wj-7m2f lists affected ranges: Packagist yeswiki/yeswiki >=0 <4.6.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-52777: 0.28% estimated exploitation activity in the next 30 days; percentile 20.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Details Sink tools/bazar/services/CSVManager.php line 372-399: There is no ['allowedclasses' = false] argument; arbitrary classes are instantiated. The subsequent arraymap('strval', $entry) additionally exercises toString on each top-level array element, doubling the magic-method surface available to a gadget chain. Source tools/bazar/actions/BazarImportAction.php: $POST['importfiche'] flows directly to the sink. The mode switches to 'importentries' whenever the request body contains the key, so an attacker need only POST importfiche[0]=<payload. Reachability 1. The action is registered as bazarimport. The default BazaR page (setup/sql/default-content.sql - BazaR page entry, ships with {{bazar showexportbuttons="1"}}) routes ?BazaR&vue=importer&idtypeannonce=<N to BazarAction::run() - case VOIRIMPORTER - callAction('bazarimport', ...) (tools/bazar/actions/BazarAction.php:257-258). So the sink is reachable on a default install with no extra page authoring. 2. BazarImportAction::run()…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9369-69wj-7m2f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-52777 Advisory: YesWiki Vulnerable to Authenticated PHP Object Injection in BazarImportAction via unserialize IDs: CVE-2026-52777, GHSA-9369-69wj-7m2f Record: https://patchnext.com/advisories/cve-2026-52777 (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: yeswiki/yeswiki 4.6.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist yeswiki/yeswiki: affected < 4.6.6; fixed in 4.6.6 ## Suggested inspection (read-only) - Packagist yeswiki/yeswiki: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on yeswiki/yeswiki. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9369-69wj-7m2f (GitHub-reviewed advisory GHSA-9369-69wj-7m2f lists affected ranges: Packagist yeswiki/yeswiki >=0 <4.6.6) Commands are suggestions: review each one before running it.
Loading voting…