YesWiki Vulnerable to Reflected XSS via Unescaped Archived-Revision time Parameter in handlers/page/show.php
CVE-2026-52773GHSA-35f3-pg38-486f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (yeswiki/yeswiki 4.6.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist yeswiki/yeswiki
- Affected
- >= 4.1.0, < 4.6.6
- Fixed in
- 4.6.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-35f3-pg38-486f lists affected ranges: Packagist yeswiki/yeswiki >=4.1.0 <4.6.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-52773: 0.59% estimated exploitation activity in the next 30 days; percentile 48.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary YesWiki's archived-revision view reflects the time GET parameter into a hidden HTML input in handlers/page/show.php without escaping. Because MySQL coerces malformed DATETIME strings, an attacker can append HTML or JavaScript to a valid archived revision timestamp, still load that archived revision, and execute arbitrary JavaScript in the victim's browser. The vulnerable form is only rendered when the victim can both read and edit the target page. In restricted deployments this requires a victim with read and write access to that page. On a default doryphore 4.6.5 install, public pages such as PagePrincipale were editable anonymously during validation, so the issue can also affect unauthenticated visitors in that configuration. Details The request routing path uses the user-controlled time parameter to load a specific page revision. In includes/YesWiki.php around Run() line 1223, the request is routed through: LoadPage() delegates to PageManager::getOne() in…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-35f3-pg38-486f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-52773 Advisory: YesWiki Vulnerable to Reflected XSS via Unescaped Archived-Revision `time` Parameter in `handlers/page/show.php` IDs: CVE-2026-52773, GHSA-35f3-pg38-486f Record: https://patchnext.com/advisories/cve-2026-52773 (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: yeswiki/yeswiki 4.6.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist yeswiki/yeswiki: affected >= 4.1.0, < 4.6.6; fixed in 4.6.6 ## Suggested inspection (read-only) - Packagist yeswiki/yeswiki: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on yeswiki/yeswiki. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-35f3-pg38-486f (GitHub-reviewed advisory GHSA-35f3-pg38-486f lists affected ranges: Packagist yeswiki/yeswiki >=4.1.0 <4.6.6) Commands are suggestions: review each one before running it.
Loading voting…