YesWiki has stored XSS in Bazar form-field templates via unescaped field.label / field.hint (|raw('html'))
CVE-2026-52772GHSA-xc7j-3g8q-9vh4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (yeswiki/yeswiki 4.6.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist yeswiki/yeswiki
- Affected
- < 4.6.6
- Fixed in
- 4.6.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xc7j-3g8q-9vh4 lists affected ranges: Packagist yeswiki/yeswiki >=0 <4.6.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-52772: 0.34% estimated exploitation activity in the next 30 days; percentile 27.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Bazar form-field templates still apply |raw('html') to field.label / field.hint in attribute and label-body contexts — stored XSS in form renders (sibling class of commit e6b66aa) CWE: CWE-79 (Improper Neutralization of Input During Web Page Generation, "Cross-site Scripting") via CWE-116 (Improper Encoding or Escaping of Output) — same class as the partial fix at commit e6b66aa CVSS v3.1: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N → 4.7 (Medium) (Privileges Required = High because writing the field definitions requires saisieformulaire, which tools/bazar/services/Guard.php:58-61 grants only to admins by default; Scope = Changed because the XSS payload set by a form-editor admin executes in the origin context of arbitrary viewers, including unauthenticated visitors.) Summary Commit e6b66aa ("fix(bazar): leave the twig escape placeholder as is", 2026-05-19) recognised that emitting field.label through Twig's raw('html') filter into an HTML attribute is unsafe — Twig's raw marker…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xc7j-3g8q-9vh4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-52772
Advisory: YesWiki has stored XSS in Bazar form-field templates via unescaped field.label / field.hint (|raw('html'))
IDs: CVE-2026-52772, GHSA-xc7j-3g8q-9vh4
Record: https://patchnext.com/advisories/cve-2026-52772 (revision 1, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: yeswiki/yeswiki 4.6.6. A vendor fix does not mean a deployment is fixed.
## Affected components
- Packagist yeswiki/yeswiki: affected < 4.6.6; fixed in 4.6.6
## Suggested inspection (read-only)
- Packagist yeswiki/yeswiki: check the installed version with your package manager.
## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.
## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on yeswiki/yeswiki.
- Repeat the inspection and confirm that only fixed versions remain installed.
## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.
## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.
## Sources
- Verified: https://github.com/advisories/GHSA-xc7j-3g8q-9vh4 (GitHub-reviewed advisory GHSA-xc7j-3g8q-9vh4 lists affected ranges: Packagist yeswiki/yeswiki >=0 <4.6.6)
Commands are suggestions: review each one before running it.Loading voting…