YesWiki Vulnerable to Unauthenticated ActivityPub Signature-Verification Bypass via !openssl_verify(...) accepting int(-1)
CVE-2026-52767GHSA-mv28-wj57-f57g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (yeswiki/yeswiki 4.6.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist yeswiki/yeswiki
- Affected
- >= 4.6.2, < 4.6.6
- Fixed in
- 4.6.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mv28-wj57-f57g lists affected ranges: Packagist yeswiki/yeswiki >=4.6.2 <4.6.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:L
- EPSS
- CVE-2026-52767: 0.35% estimated exploitation activity in the next 30 days; percentile 28.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary HttpSignatureService::verifySignature() checks the result of PHP's opensslverify() with a loose boolean negation - if (!opensslverify(...)) { throw ... }. PHP's opensslverify has four possible return values: | return | meaning | !return | | ------ | ------------------------------------------------ | --------- | | 1 | signature is valid | false | | 0 | signature is invalid | true ✓ | | -1 | the verify call itself failed (internal error) | false ❌ | | false| input rejected by PHP's argument validation | true ✓ | The -1 row is the bypass: PHP's truthiness rules make -1 a truthy value, so !(-1) === false, the throw is skipped, and the controller proceeds to processActivity(). Any condition that makes OpenSSL's EVPVerifyFinal() return -1 triggers the bypass. The two practical paths to -1 we are aware of: 1. DSA / EC public key with an RSA-only algorithm. opensslverify(..., $dsaKey, "RSA-SHA256") returns int(-1) on PHP 8.3 + OpenSSL 3.x. This is the path the PoC uses; it works…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mv28-wj57-f57g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-52767 Advisory: YesWiki Vulnerable to Unauthenticated ActivityPub Signature-Verification Bypass via `!openssl_verify(...)` accepting `int(-1)` IDs: CVE-2026-52767, GHSA-mv28-wj57-f57g Record: https://patchnext.com/advisories/cve-2026-52767 (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: yeswiki/yeswiki 4.6.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist yeswiki/yeswiki: affected >= 4.6.2, < 4.6.6; fixed in 4.6.6 ## Suggested inspection (read-only) - Packagist yeswiki/yeswiki: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on yeswiki/yeswiki. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mv28-wj57-f57g (GitHub-reviewed advisory GHSA-mv28-wj57-f57g lists affected ranges: Packagist yeswiki/yeswiki >=4.6.2 <4.6.6) Commands are suggestions: review each one before running it.
Loading voting…