Skip to content

← Actionable
High, CVSS 7.5amended

jsonata: Malicious inputs to "$toMillis" function can cause resource exhaustion

CVE-2026-52746GHSA-86vw-mfpg-wwv9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jsonata 2.2.0, 1.8.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm jsonata

    Affected
    >= 2.0.0, < 2.2.0< 1.8.9
    Fixed in
    2.2.0, 1.8.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-52746: 0.69% estimated exploitation activity in the next 30 days; percentile 52.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Before JSONata 2.2.0 and 1.8.9, it is possible to craft non-matching inputs to the $toMillis function that cause superlinear backtracking in the ISO-8601 validation regex. This may lead to denial of service in applications that evaluate user-provided JSONata expressions. Patches This issue has been addressed in JSONata version 2.2.0 or later, and 1.8.9 or later on v1, via fixes that include https://github.com/jsonata-js/jsonata/pull/782 and https://github.com/jsonata-js/jsonata/pull/793. Applications that evaluate user-provided expressions should update ASAP to prevent exploitation. References https://github.com/jsonata-js/jsonata/releases/tag/v2.2.0 https://github.com/jsonata-js/jsonata/releases/tag/v1.8.9 Credit Thank you to Doruk Tan Öztürk for disclosing this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-86vw-mfpg-wwv9

  2. Revision 1 · created ·

    Published from osv record GHSA-86vw-mfpg-wwv9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-52746

Advisory: jsonata: Malicious inputs to "$toMillis" function can cause resource exhaustion
IDs: CVE-2026-52746, GHSA-86vw-mfpg-wwv9
Record: https://patchnext.com/advisories/cve-2026-52746 (revision 2, source checked 26 Oct 2026, 13:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jsonata 2.2.0, 1.8.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm jsonata: affected >= 2.0.0, < 2.2.0; < 1.8.9; fixed in 2.2.0, 1.8.9

## Suggested inspection (read-only)
- `npm ls jsonata --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jsonata.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-86vw-mfpg-wwv9 (OSV record GHSA-86vw-mfpg-wwv9 lists affected ranges: npm jsonata >=2.0.0 =0 <1.8.9 (fixed))
- Verified: https://github.com/advisories/GHSA-86vw-mfpg-wwv9 (GitHub-reviewed advisory GHSA-86vw-mfpg-wwv9 lists affected ranges: npm jsonata >=2.0.0 =0 <1.8.9)

Commands are suggestions: review each one before running it.

Loading voting…