zebrad has full node denial of service via non-ASCII LongPollId in getblocktemplate
CVE-2026-52731GHSA-qv2r-v3mx-f4pf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zebra-rpc 8.0.0; zebrad 4.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qv2r-v3mx-f4pf lists affected ranges: crates.io zebra-rpc >=0 =0 <=4.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-52731: 0.53% estimated exploitation activity in the next 30 days; percentile 44.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Am I affected You are affected if: 1. You run zebrad up to and including v4.4.1. 2. Your zebrad.toml sets rpc.listenaddr to a TCP address (RPC server is enabled). 3. An attacker can authenticate to the RPC endpoint. With the default enablecookieauth = true, this requires the attacker to read the .cookie file. With enablecookieauth = false, any network client reaching the RPC port can trigger it. Summary The getblocktemplate RPC handler panics when parsing a LongPollId parameter that contains non-ASCII (multi-byte UTF-8) characters. The handler performs byte-index string slicing on the user-supplied string, which panics in Rust when a byte index falls within a multi-byte character boundary. Because Zebra's release profile sets panic = "abort", the panic terminates the entire node process. Details The getblocktemplate handler receives a user-supplied LongPollId string and slices it at fixed byte offsets to extract the encoded tip hash and tip height. When the string contains multi-byte…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qv2r-v3mx-f4pf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-52731 Advisory: zebrad has full node denial of service via non-ASCII LongPollId in getblocktemplate IDs: CVE-2026-52731, GHSA-qv2r-v3mx-f4pf Record: https://patchnext.com/advisories/cve-2026-52731 (revision 1, source checked 26 Oct 2026, 15:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zebra-rpc 8.0.0; zebrad 4.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io zebra-rpc: affected <= 7.0.0; fixed in 8.0.0 - crates.io zebrad: affected <= 4.4.1; fixed in 4.5.0 ## Suggested inspection (read-only) - crates.io zebra-rpc: check the installed version with your package manager. - crates.io zebrad: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zebra-rpc, zebrad. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qv2r-v3mx-f4pf (GitHub-reviewed advisory GHSA-qv2r-v3mx-f4pf lists affected ranges: crates.io zebra-rpc >=0 =0 <=4.4.1) Commands are suggestions: review each one before running it.
Loading voting…