Skip to content

← Actionable
Medium, CVSS 5.3amended

@angular/core: Angular Template and Dynamic Component Namespace Bypass leading to Cross-Site Scripting (XSS)

CVE-2026-52725GHSA-692r-grfm-v8x7

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @angular/core

    Affected
    >= 21.0.0-next.0, < 21.2.15>= 22.0.0-next.0, < 22.0.0-rc.2>= 19.0.0-next.0, < 19.2.23<= 18.2.14>= 20.0.0-next.0, < 20.3.22
    Fixed in
    21.2.15, 22.0.0-rc.2, 19.2.23, 20.3.22

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-52725: 0.46% estimated exploitation activity in the next 30 days; percentile 39.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue in the `@angular/core` package allows bypassing script-execution restrictions during dynamic component creation. Specifically, the dynamic component instantiation mechanism (`createComponent`) failed to reject mounting components directly onto a ` ` or namespaced script element (such as ` `). This enabled the initialization of custom components on a tag that executes scripts, allowing attackers to hijack or inject script-executing hosts. This flaw enables an attacker who can control the host element or selector parameter passed to `createComponent` to initialize or mount an Angular component directly onto a ` ` tag, leading to execution of untrusted code or client-side Cross-Site Scripting (XSS).

Impact Any Angular application that registers dynamic components based on user-supplied parameters (like selectors or host elements) is vulnerable to this security bypass. Once exploited, this allows a malicious actor to mount a dynamic component on a script tag, bypassing core…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  2. Revision 1 · created ·

    Published from osv record GHSA-692r-grfm-v8x7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-52725

Advisory: @angular/core: Angular Template and Dynamic Component Namespace Bypass leading to Cross-Site Scripting (XSS)
IDs: CVE-2026-52725, GHSA-692r-grfm-v8x7
Record: https://patchnext.com/advisories/cve-2026-52725 (revision 2, source checked 24 Oct 2026, 22:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: @angular/core 22.0.0-rc.2, 21.2.15, 20.3.22, 19.2.23. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @angular/core: affected >= 21.0.0-next.0, < 21.2.15; >= 22.0.0-next.0, < 22.0.0-rc.2; >= 19.0.0-next.0, < 19.2.23; <= 18.2.14; >= 20.0.0-next.0, < 20.3.22; fixed in 21.2.15, 22.0.0-rc.2, 19.2.23, 20.3.22

## Suggested inspection (read-only)
- `npm ls @angular/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @angular/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-692r-grfm-v8x7 (OSV record GHSA-692r-grfm-v8x7 lists affected ranges: npm @angular/core >=21.0.0-next.0 =22.0.0-next.0 =19.0.0-next.0 =0 =20.0.0-next.0 <20.3.22 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…