Skip to content

← Actionable
Medium, CVSS 5.8

kuma-dp connects to control plane without verifying TLS certificate when no CA is configured

CVE-2026-52724GHSA-wvmp-6r4v-j6cv

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/kumahq/kuma

    Affected
    <= 1.8.1
    Fixed in
    no fixed version recorded
  • Go github.com/kumahq/kuma/v2

    Affected
    < 2.7.26>= 2.8.0, < 2.9.16>= 2.10.0, < 2.11.14>= 2.12.0, < 2.12.11>= 2.13.0, < 2.13.7
    Fixed in
    2.7.26, 2.13.7, 2.11.14, 2.9.16, 2.12.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.8 · CVSS:4.0/AV:A/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-52724: 0.35% estimated exploitation activity in the next 30 days; percentile 28.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

When kuma-dp is started against an HTTPS control plane and the operator did not pass a CA certificate, the data plane connects with TLS peer verification disabled. The dataplane authentication token is sent over this unverified connection Impact An on-path attacker can intercept the dataplane authentication token and impersonate the control plane to the data plane, allowing them to inject a forged bootstrap configuration and take over the proxy Affected configurations - Universal mode kuma-dp started against an HTTPS control plane without --ca-cert-file (or KUMACONTROLPLANECACERT unset) Not affected - Kubernetes installs done through the standard installers (kumactl install control-plane or the official Helm chart). In both cases the control plane's mutating admission webhook injects KUMACONTROLPLANECACERT into every sidecar at pod admission, so each kuma-dp starts with the CA already configured Workarounds Set --ca-cert-file (or KUMACONTROLPLANECACERT) on every Universal mode data…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wvmp-6r4v-j6cv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-52724

Advisory: kuma-dp connects to control plane without verifying TLS certificate when no CA is configured
IDs: CVE-2026-52724, GHSA-wvmp-6r4v-j6cv
Record: https://patchnext.com/advisories/cve-2026-52724 (revision 1, source checked 26 Oct 2026, 15:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: github.com/kumahq/kuma/v2 2.13.7, 2.12.11, 2.11.14, 2.9.16, 2.7.26. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/kumahq/kuma: affected <= 1.8.1
- Go github.com/kumahq/kuma/v2: affected < 2.7.26; >= 2.8.0, < 2.9.16; >= 2.10.0, < 2.11.14; >= 2.12.0, < 2.12.11; >= 2.13.0, < 2.13.7; fixed in 2.7.26, 2.13.7, 2.11.14, 2.9.16, 2.12.11

## Suggested inspection (read-only)
- Go github.com/kumahq/kuma: check the installed version with your package manager.
- Go github.com/kumahq/kuma/v2: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/kumahq/kuma, github.com/kumahq/kuma/v2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wvmp-6r4v-j6cv (GitHub-reviewed advisory GHSA-wvmp-6r4v-j6cv lists affected ranges: Go github.com/kumahq/kuma/v2 >=0 =2.8.0 =2.10.0 =2.12.0 =2.13.0 =0 <=1.8.1)

Commands are suggestions: review each one before running it.

Loading voting…