huggingface/transformers: Arbitrary Code Execution During Model Initialization in the LightGlue Model Loading Path
CVE-2026-5241GHSA-fgcw-684q-jj6r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (transformers 5.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI transformers
- Affected
- < 5.5.0
- Fixed in
- 5.5.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fgcw-684q-jj6r lists affected ranges: PyPI transformers >=0 <5.5.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fgcw-684q-jj6r lists affected ranges: PyPI transformers >=0 <5.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.0 · CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N
- EPSS
- CVE-2026-5241: 0.60% estimated exploitation activity in the next 30 days; percentile 48.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability in the LightGlue model loading path of huggingface/transformers version 5.2.0 allows an attacker-controlled model repository to execute arbitrary code during model initialization. The issue arises because the trustremotecode parameter, intended to prevent remote code execution, is overridden by untrusted serialized configuration data in a nested code path. Specifically, when loading a LightGlue model using AutoModel.frompretrained() with trustremotecode=False, the LightGlueConfig reads the trustremotecode value from the untrusted config.json file and propagates it into nested AutoConfig.frompretrained() calls. This results in the execution of attacker-provided Python modules, even when the victim explicitly disables remote code execution. The vulnerability poses a high risk for environments such as API inference servers, research notebooks, CI/CD pipelines, and model evaluation workers, potentially leading to credential theft, lateral movement, or persistence/backdoor…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-fgcw-684q-jj6r
- Revision 1 · created ·
Published from osv record GHSA-fgcw-684q-jj6r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-5241 Advisory: huggingface/transformers: Arbitrary Code Execution During Model Initialization in the LightGlue Model Loading Path IDs: CVE-2026-5241, GHSA-fgcw-684q-jj6r Record: https://patchnext.com/advisories/cve-2026-5241 (revision 2, source checked 26 Oct 2026, 13:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: transformers 5.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI transformers: affected < 5.5.0; fixed in 5.5.0 ## Suggested inspection (read-only) - `python -m pip show transformers`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on transformers. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fgcw-684q-jj6r (OSV record GHSA-fgcw-684q-jj6r lists affected ranges: PyPI transformers >=0 <5.5.0 (fixed)) - Verified: https://github.com/advisories/GHSA-fgcw-684q-jj6r (GitHub-reviewed advisory GHSA-fgcw-684q-jj6r lists affected ranges: PyPI transformers >=0 <5.5.0) Commands are suggestions: review each one before running it.
Loading voting…