Langflow: Title Authenticated Remote Code Execution in validate_code via Malicious Decorators Description
CVE-2026-51886GHSA-w584-2h2r-2hvf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langflow 1.10.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langflow
- Affected
- >= 1.7.2, < 1.10.1
- Fixed in
- 1.10.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w584-2h2r-2hvf lists affected ranges: PyPI langflow >=1.7.2 <1.10.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w584-2h2r-2hvf lists affected ranges: PyPI langflow >=1.7.2 <1.10.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-51886: 0.60% estimated exploitation activity in the next 30 days; percentile 48.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
###Summary: A critical Authenticated Remote Code Execution (RCE) vulnerability exists in the validatecode function of Langflow. The /api/v1/validate/code endpoint, meant to validate user-supplied code, leverages Python's exec() function. While it attempts to restrict execution to function definitions, it fails to account for decorators, which are evaluated at definition time. This allows any authenticated user to execute arbitrary code on the server, resulting in a full system compromise. Details The vulnerability is located in src/lfx/src/lfx/custom/validate.py(exposed via src/backend/base/langflow/api/v1/validate.py). The validatecode function parses user input using ast. When it encounters a FunctionDef node, it compiles and executes it to check for extensive errors: By design, executing a function definition (def func(): ...) does not execute the function body. However, Python immediately evaluates decorators attached to the function definition. An attacker can supply a malicious…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-w584-2h2r-2hvf
- Revision 2 · amended ·
Amended from osv record GHSA-w584-2h2r-2hvf
- Revision 1 · created ·
Published from ghsa record GHSA-w584-2h2r-2hvf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-51886 Advisory: Langflow: Title Authenticated Remote Code Execution in validate_code via Malicious Decorators Description IDs: CVE-2026-51886, GHSA-w584-2h2r-2hvf Record: https://patchnext.com/advisories/cve-2026-51886 (revision 3, source checked 26 Oct 2026, 13:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langflow 1.10.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langflow: affected >= 1.7.2, < 1.10.1; fixed in 1.10.1 ## Suggested inspection (read-only) - `python -m pip show langflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w584-2h2r-2hvf (GitHub-reviewed advisory GHSA-w584-2h2r-2hvf lists affected ranges: PyPI langflow >=1.7.2 <1.10.1) - Verified: https://osv.dev/vulnerability/GHSA-w584-2h2r-2hvf (OSV record GHSA-w584-2h2r-2hvf lists affected ranges: PyPI langflow >=1.7.2 <1.10.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…