goldmark vulnerable to Cross-site Scripting (XSS)
CVE-2026-5160GHSA-c97m-vxhj-p7j6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/yuin/goldmark/renderer/html 1.7.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/yuin/goldmark/renderer/html
- Affected
- < 1.7.17
- Fixed in
- 1.7.17
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c97m-vxhj-p7j6 lists affected ranges: Go github.com/yuin/goldmark/renderer/html >=0 <1.7.17
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-5160: 0.29% estimated exploitation activity in the next 30 days; percentile 21.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of the package github.com/yuin/goldmark/renderer/html before 1.7.17 are vulnerable to Cross-site Scripting (XSS) due to improper ordering of URL validation and normalization. The renderer validates link destinations using a prefix-based check (IsDangerousURL) before resolving HTML entities. This allows an attacker to bypass protocol filtering by encoding dangerous schemes using HTML5 named character references. For example, a payload such as javascript:alert(1) is not recognized as dangerous during validation, leading to arbitrary script execution in the context of applications that render the URL.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c97m-vxhj-p7j6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-5160 Advisory: goldmark vulnerable to Cross-site Scripting (XSS) IDs: CVE-2026-5160, GHSA-c97m-vxhj-p7j6 Record: https://patchnext.com/advisories/cve-2026-5160 (revision 1, source checked 26 Oct 2026, 15:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/yuin/goldmark/renderer/html 1.7.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/yuin/goldmark/renderer/html: affected < 1.7.17; fixed in 1.7.17 ## Suggested inspection (read-only) - Go github.com/yuin/goldmark/renderer/html: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/yuin/goldmark/renderer/html. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c97m-vxhj-p7j6 (GitHub-reviewed advisory GHSA-c97m-vxhj-p7j6 lists affected ranges: Go github.com/yuin/goldmark/renderer/html >=0 <1.7.17) Commands are suggestions: review each one before running it.
Loading voting…