Mattermost doesn't enforce administrator authorization on the {{setDefaultInstance}} call within the {{/gitlab connect}} command handler
CVE-2026-5139GHSA-2g8v-grq3-hq2g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost-server 11.7.1, 11.6.3, 11.5.6, 10.11.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost-server
- Affected
- >= 11.7.0, < 11.7.1>= 11.6.0, < 11.6.3>= 11.5.0, < 11.5.6>= 10.11.0, < 10.11.18
- Fixed in
- 11.6.3, 11.7.1, 10.11.18, 11.5.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6480 lists affected ranges: Go github.com/mattermost/mattermost-server >=10.11.0+incompatible =11.5.0+incompatible =11.6.0+incompatible =11.7.0+incompatible <11.7.1+incompatible (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2g8v-grq3-hq2g lists affected ranges: Go github.com/mattermost/mattermost-server >=11.7.0 =11.6.0 =11.5.0 =10.11.0 <10.11.18
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
- EPSS
- CVE-2026-5139: 0.29% estimated exploitation activity in the next 30 days; percentile 21.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost versions 11.7.x <= 11.7.0, 11.6.x <= 11.6.2, 11.5.x <= 11.5.5, 10.11.x <= 10.11.17 fail to enforce administrator authorization on the {{setDefaultInstance}} call within the {{/gitlab connect}} command handler, which allows any authenticated user to overwrite the global default GitLab instance configuration via the {{/gitlab connect <instance-name}} slash command.. Mattermost Advisory ID: MMSA-2026-00644
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-2g8v-grq3-hq2g
- Revision 1 · created ·
Published from osv record GO-2026-6480
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-5139
Advisory: Mattermost doesn't enforce administrator authorization on the {{setDefaultInstance}} call within the {{/gitlab connect}} command handler
IDs: CVE-2026-5139, GHSA-2g8v-grq3-hq2g
Record: https://patchnext.com/advisories/cve-2026-5139 (revision 2, source checked 26 Oct 2026, 15:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost-server 11.7.1, 11.6.3, 11.5.6, 10.11.18. A vendor fix does not mean a deployment is fixed.
## Affected components
- Go github.com/mattermost/mattermost-server: affected >= 11.7.0, < 11.7.1; >= 11.6.0, < 11.6.3; >= 11.5.0, < 11.5.6; >= 10.11.0, < 10.11.18; fixed in 11.6.3, 11.7.1, 10.11.18, 11.5.6
## Suggested inspection (read-only)
- Go github.com/mattermost/mattermost-server: check the installed version with your package manager.
## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.
## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/mattermost/mattermost-server.
- Repeat the inspection and confirm that only fixed versions remain installed.
## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.
## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.
## Sources
- Verified: https://osv.dev/vulnerability/GO-2026-6480 (OSV record GO-2026-6480 lists affected ranges: Go github.com/mattermost/mattermost-server >=10.11.0+incompatible =11.5.0+incompatible =11.6.0+incompatible =11.7.0+incompatible <11.7.1+incompatible (fixed))
- Verified: https://github.com/advisories/GHSA-2g8v-grq3-hq2g (GitHub-reviewed advisory GHSA-2g8v-grq3-hq2g lists affected ranges: Go github.com/mattermost/mattermost-server >=11.7.0 =11.6.0 =11.5.0 =10.11.0 <10.11.18)
Commands are suggestions: review each one before running it.Loading voting…