Skip to content

← Actionable
High, CVSS 7.5

Microsoft Security Advisory CVE-2026-50648 – .NET Denial of Service Vulnerability

CVE-2026-50648GHSA-23rf-6693-g89p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (system.security.cryptography.xml 10.0.10, 9.0.18, 8.0.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-50648: 1.17% estimated exploitation activity in the next 30 days; percentile 67.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Executive summary Microsoft is releasing this security advisory to provide information about a vulnerability in .NET XML Encryption (System.Security.Cryptography.Xml). This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. A denial of service vulnerability exists in the XML encryption implementation (EncryptedXml) in .NET 8, .NET 9, and .NET 10. An attacker could exploit this vulnerability by supplying crafted encrypted XML that causes uncontrolled resource consumption, resulting in denial of service. Announcement Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/416 CVSS Details - Version: 3.1 - Severity: High - Score: 7.5 - Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling) Affected Platforms - Platforms: All - Architectures: All <a name="affected-packages"</aAffected Packages The vulnerability…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-23rf-6693-g89p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-50648

Advisory: Microsoft Security Advisory CVE-2026-50648 – .NET Denial of Service Vulnerability
IDs: CVE-2026-50648, GHSA-23rf-6693-g89p
Record: https://patchnext.com/advisories/cve-2026-50648 (revision 1, source checked 26 Oct 2026, 17:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: system.security.cryptography.xml 10.0.10, 9.0.18, 8.0.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet system.security.cryptography.xml: affected >= 10.0.0, <= 10.0.9; >= 9.0.0, <= 9.0.17; >= 8.0.0, <= 8.0.3; fixed in 8.0.4, 10.0.10, 9.0.18

## Suggested inspection (read-only)
- NuGet system.security.cryptography.xml: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on system.security.cryptography.xml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-23rf-6693-g89p (GitHub-reviewed advisory GHSA-23rf-6693-g89p lists affected ranges: NuGet system.security.cryptography.xml >=10.0.0 =9.0.0 =8.0.0 <=8.0.3)

Commands are suggestions: review each one before running it.

Loading voting…