Skip to content

← Actionable
High, CVSS 8.3amended

yt-dlp: Arbitrary code execution via manifest downloads with aria2c

CVE-2026-50574GHSA-vx4q-3cr2-7cg2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (yt-dlp 2026.6.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI yt-dlp

    Affected
    < 2026.6.9
    Fixed in
    2026.6.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.3 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-50574: 0.46% estimated exploitation activity in the next 30 days; percentile 40.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary If aria2c is used as an external downloader for a fragmented manifest format (such as an HLS/DASH stream), yt-dlp passes insufficiently sanitized input to aria2c that allows an attacker to perform an arbitrary file write. On Windows platforms, this can lead to immediate arbitrary code execution. On non-Windows platforms, this can lead to arbitrary code execution upon the next invocation of yt-dlp. Details When downloading a fragmented manifest format such as an HLS or DASH stream, yt-dlp first extracts a list of all fragment URLs from the stream's manifest. If the user has selected aria2c as an external downloader, yt-dlp then constructs an input file for aria2c from the fragment URL list and passes its filepath as the argument to aria2c's -i option. aria2c's -i (or --input-file) option allows for downloading a list of URIs from the given text file. The text file must be formatted as a list of URIs separated by newlines. aria2c's format permits configuration lines for each…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vx4q-3cr2-7cg2

  2. Revision 1 · created ·

    Published from osv record GHSA-vx4q-3cr2-7cg2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-50574

Advisory: yt-dlp: Arbitrary code execution via manifest downloads with aria2c
IDs: CVE-2026-50574, GHSA-vx4q-3cr2-7cg2
Record: https://patchnext.com/advisories/cve-2026-50574 (revision 2, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: yt-dlp 2026.6.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI yt-dlp: affected < 2026.6.9; fixed in 2026.6.9

## Suggested inspection (read-only)
- `python -m pip show yt-dlp`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on yt-dlp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vx4q-3cr2-7cg2 (OSV record GHSA-vx4q-3cr2-7cg2 lists affected ranges: PyPI yt-dlp >=0 <2026.6.9 (fixed))
- Verified: https://github.com/advisories/GHSA-vx4q-3cr2-7cg2 (GitHub-reviewed advisory GHSA-vx4q-3cr2-7cg2 lists affected ranges: PyPI yt-dlp >=0 <2026.6.9)

Commands are suggestions: review each one before running it.

Loading voting…