pnpm: Unsafe default behavior breaks integrity check
CVE-2026-50573GHSA-54hh-g5mx-jqcp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pnpm 11.4.0, 10.34.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm pnpm
- Affected
- < 10.34.0>= 11.0.0, < 11.4.0
- Fixed in
- 10.34.0, 11.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-54hh-g5mx-jqcp lists affected ranges: npm pnpm >=0 =11.0.0 <11.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-54hh-g5mx-jqcp lists affected ranges: npm pnpm >=0 =11.0.0 <11.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-50573: 0.17% estimated exploitation activity in the next 30 days; percentile 6.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
While it is unclear whether this should be classified as a vulnerability, it is being reported through this channel because the current behavior may represent an unsafe default. Summary pnpm install in non-frozen mode can accept new remote package content after detecting that the downloaded tarball does not match the integrity recorded in pnpm-lock.yaml. When a package is already locked with an integrity value, and the registry later serves different metadata and tarball content for the same package name and version, pnpm initially reports an integrity mismatch. However, plain pnpm install then performs a resolution repair, accepts the registry's new integrity, updates the lockfile, installs the new content, and exits successfully. This means the lockfile integrity check does not act as a hard stop by default. Reproduction Scenario 1. Run a local npm-compatible registry. 2. Publish or serve example-package@1.0.0 with tarball content v1. 3. Install it with pnpm: 4. Confirm…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-54hh-g5mx-jqcp
- Revision 1 · created ·
Published from osv record GHSA-54hh-g5mx-jqcp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-50573 Advisory: pnpm: Unsafe default behavior breaks integrity check IDs: CVE-2026-50573, GHSA-54hh-g5mx-jqcp Record: https://patchnext.com/advisories/cve-2026-50573 (revision 2, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pnpm 11.4.0, 10.34.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm pnpm: affected < 10.34.0; >= 11.0.0, < 11.4.0; fixed in 10.34.0, 11.4.0 ## Suggested inspection (read-only) - `npm ls pnpm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pnpm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-54hh-g5mx-jqcp (OSV record GHSA-54hh-g5mx-jqcp lists affected ranges: npm pnpm >=0 =11.0.0 <11.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-54hh-g5mx-jqcp (GitHub-reviewed advisory GHSA-54hh-g5mx-jqcp lists affected ranges: npm pnpm >=0 =11.0.0 <11.4.0) Commands are suggestions: review each one before running it.
Loading voting…