Netty susceptible to HTTP/2 Reset Attack with different on-the-wire signature
CVE-2026-50560GHSA-563q-j3cm-6jxm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-codec-http2 4.2.15.Final, 4.1.135.Final), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.netty:netty-codec-http2
- Affected
- >= 4.2.0.Final, <= 4.2.14.Final<= 4.1.134.Final
- Fixed in
- 4.2.15.Final, 4.1.135.Final
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-563q-j3cm-6jxm lists affected ranges: Maven io.netty:netty-codec-http2 >=4.2.0.Final =0 <=4.1.134.Final
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-50560: 0.40% estimated exploitation activity in the next 30 days; percentile 33.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Netty HTTP/2 max header size handling produces attack similar to HTTP/2 Rapid Reset. Details There is a setting in the http2 specification called SETTINGSMAXHEADERLISTSIZE. According to the RFC: “This advisory setting informs a peer of the maximum field section size that the sender is prepared to accept, in units of octets.” When a client sends that setting to Netty, it appears that Netty will behave as follows: - Read the request - Proxy the request to the origin - Attempt to produce a response - Create an exception while writing the headers for the response Functionally, this should be similar to the http2 reset attack, but with a different on-the-wire signature. Remediation When speaking with clients, Netty should potentially treat this as “advisory” and ignore it. It would be best to ignore the SETTINGSMAXHEADERLISTSIZE setting from clients (or ignore it when sending to clients). According to the spec, a server does not need to honor this advisory setting, and it appears…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-563q-j3cm-6jxm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-50560 Advisory: Netty susceptible to HTTP/2 Reset Attack with different on-the-wire signature IDs: CVE-2026-50560, GHSA-563q-j3cm-6jxm Record: https://patchnext.com/advisories/cve-2026-50560 (revision 1, source checked 26 Oct 2026, 16:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-codec-http2 4.2.15.Final, 4.1.135.Final. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.netty:netty-codec-http2: affected >= 4.2.0.Final, <= 4.2.14.Final; <= 4.1.134.Final; fixed in 4.2.15.Final, 4.1.135.Final ## Suggested inspection (read-only) - Maven io.netty:netty-codec-http2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.netty:netty-codec-http2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-563q-j3cm-6jxm (GitHub-reviewed advisory GHSA-563q-j3cm-6jxm lists affected ranges: Maven io.netty:netty-codec-http2 >=4.2.0.Final =0 <=4.1.134.Final) Commands are suggestions: review each one before running it.
Loading voting…