Penelope unsafe tar extraction allows arbitrary local file write via crafted session archive
CVE-2026-50558GHSA-f42x-p2mx-hm8r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (penelope-shell-handler 0.20.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.20.0
- Fixed in
- 0.20.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f42x-p2mx-hm8r lists affected ranges: PyPI penelope-shell-handler >=0 <0.20.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:L
- EPSS
- CVE-2026-50558: 0.37% estimated exploitation activity in the next 30 days; percentile 30.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Penelope versions prior to 0.19.3 extracted tar archives received from remote sessions without validating archive member paths. When using the affected Unix download path, a malicious or compromised remote session could return a crafted tar archive containing path traversal entries, such as ../, causing files to be written outside the intended download directory on the Penelope operator's machine. The impact is limited to files writable by the user running Penelope. In some cases, this arbitrary file write could be chained to operator-side code execution if the attacker can overwrite a file that Penelope or the user later executes, such as ~/.penelope/peneloperc. The issue has been fixed in version 0.19.3 by rejecting unsafe archive paths during extraction. Affected conditions The issue requires the operator to use the Main Menu download command to download files from a malicious or compromised remote session that can influence the tar archive returned to Penelope. The Python…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f42x-p2mx-hm8r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-50558 Advisory: Penelope unsafe tar extraction allows arbitrary local file write via crafted session archive IDs: CVE-2026-50558, GHSA-f42x-p2mx-hm8r Record: https://patchnext.com/advisories/cve-2026-50558 (revision 1, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: penelope-shell-handler 0.20.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI penelope-shell-handler: affected < 0.20.0; fixed in 0.20.0 ## Suggested inspection (read-only) - `python -m pip show penelope-shell-handler`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on penelope-shell-handler. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f42x-p2mx-hm8r (GitHub-reviewed advisory GHSA-f42x-p2mx-hm8r lists affected ranges: PyPI penelope-shell-handler >=0 <0.20.0) Commands are suggestions: review each one before running it.
Loading voting…