Angular: Template and Attribute Namespace Sanitization Bypass (XSS)
CVE-2026-50557GHSA-f3m7-gqxr-g87x
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 21.0.0-next.0, < 21.2.15>= 22.0.0-next.0, < 22.0.0-rc.2>= 20.0.0-next.0, < 20.3.22>= 19.0.0-next.0, < 19.2.22<= 18.2.14
- Fixed in
- 19.2.22, 22.0.0-rc.2, 20.3.22, 21.2.15
npm @angular/core
- Affected
- >= 21.0.0-next.0, < 21.2.15>= 22.0.0-next.0, < 22.0.0-rc.2>= 20.0.0-next.0, < 20.3.22>= 19.0.0-next.0, < 19.2.22<= 18.2.14
- Fixed in
- 19.2.22, 22.0.0-rc.2, 20.3.22, 21.2.15
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f3m7-gqxr-g87x lists affected ranges: npm @angular/core >=21.0.0-next.0 =22.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 =21.0.0-next.0 =22.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f3m7-gqxr-g87x lists affected ranges: npm @angular/core >=21.0.0-next.0 =22.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 =21.0.0-next.0 =22.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-50557: 0.41% estimated exploitation activity in the next 30 days; percentile 35.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue in the @angular/compiler and @angular/core packages allows bypassing element and attribute sanitization/validation through specific namespace workarounds. Specifically, namespaced script elements (e.g., <svg:script or <:svg:script) were not properly identified as script elements by the Angular template preparser, allowing them to pass through template compilation without being stripped. Furthermore, security context schema mappings for element attributes did not consistently handle attributes within namespaced elements (like SVG and MathML), opening up gaps where malicious namespaced attributes could bypass runtime and compile-time sanitizers. Combined, these flaws enable an attacker who can inject or supply a template/tag structure with custom namespaces to bypass Angular's script-stripping logic and attribute sanitizers, leading to client-side Cross-Site Scripting (XSS). Impact Any Angular application that compiles user-controlled templates at runtime, or relies on…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-f3m7-gqxr-g87x
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-f3m7-gqxr-g87x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-50557 Advisory: Angular: Template and Attribute Namespace Sanitization Bypass (XSS) IDs: CVE-2026-50557, GHSA-f3m7-gqxr-g87x Record: https://patchnext.com/advisories/cve-2026-50557 (revision 3, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: @angular/compiler 22.0.0-rc.2, 21.2.15, 20.3.22, 19.2.22; @angular/core 22.0.0-rc.2, 21.2.15, 20.3.22, 19.2.22. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @angular/compiler: affected >= 21.0.0-next.0, < 21.2.15; >= 22.0.0-next.0, < 22.0.0-rc.2; >= 20.0.0-next.0, < 20.3.22; >= 19.0.0-next.0, < 19.2.22; <= 18.2.14; fixed in 19.2.22, 22.0.0-rc.2, 20.3.22, 21.2.15 - npm @angular/core: affected >= 21.0.0-next.0, < 21.2.15; >= 22.0.0-next.0, < 22.0.0-rc.2; >= 20.0.0-next.0, < 20.3.22; >= 19.0.0-next.0, < 19.2.22; <= 18.2.14; fixed in 19.2.22, 22.0.0-rc.2, 20.3.22, 21.2.15 ## Suggested inspection (read-only) - `npm ls @angular/compiler --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @angular/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @angular/compiler, @angular/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-f3m7-gqxr-g87x (OSV record GHSA-f3m7-gqxr-g87x lists affected ranges: npm @angular/core >=21.0.0-next.0 =22.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 =21.0.0-next.0 =22.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14) - Verified: https://github.com/advisories/GHSA-f3m7-gqxr-g87x (GitHub-reviewed advisory GHSA-f3m7-gqxr-g87x lists affected ranges: npm @angular/core >=21.0.0-next.0 =22.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 =21.0.0-next.0 =22.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14) Commands are suggestions: review each one before running it.
Loading voting…