Skip to content

← Actionable
High, CVSS 8.6amended

@angular/platform-server: Missing Raw-Text Serialization Escaping leads to Cross-Site Scripting (XSS) in Angular SSR

CVE-2026-50556GHSA-gxx4-3xcv-f8qx

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @angular/platform-server

    Affected
    >= 22.0.0-next.0, < 22.0.0-rc.2>= 21.0.0-next.0, < 21.2.16>= 20.0.0-next.0, < 20.3.24>= 19.0.0-next.0, < 19.2.25<= 18.2.14
    Fixed in
    21.2.16, 22.0.0-rc.2, 19.2.25, 20.3.24

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-50556: 0.41% estimated exploitation activity in the next 30 days; percentile 35.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A Cross-Site Scripting (XSS) vulnerability exists in @angular/platform-server's DOM emulation dependency (domino) when serializing the content of <noscript elements. When rendering dynamic text content inside a <noscript element via template bindings (such as {{ value }} or [textContent]), the template engine expects the browser to render the content safely. Under Server-Side Rendering (SSR), domino is configured with scripting enabled, meaning <noscript is treated as a raw-text element. However, domino's serializer completely omitted <noscript from the list of raw-text elements requiring closing-tag escaping during DOM serialization. As a result, any occurrence of </noscript in the bound dynamic text was never escaped under any circumstances. The unescaped closing tag was serialized directly into the output HTML (e.g. <noscript</noscript<scriptalert(1)</script</noscript). When parsed by a browser, it closes the <noscript block early, allowing the injected <script block to execute in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-gxx4-3xcv-f8qx

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-gxx4-3xcv-f8qx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-50556

Advisory: @angular/platform-server: Missing ` ` Raw-Text Serialization Escaping leads to Cross-Site Scripting (XSS) in Angular SSR
IDs: CVE-2026-50556, GHSA-gxx4-3xcv-f8qx
Record: https://patchnext.com/advisories/cve-2026-50556 (revision 3, source checked 26 Oct 2026, 12:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: @angular/platform-server 22.0.0-rc.2, 21.2.16, 20.3.24, 19.2.25. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @angular/platform-server: affected >= 22.0.0-next.0, < 22.0.0-rc.2; >= 21.0.0-next.0, < 21.2.16; >= 20.0.0-next.0, < 20.3.24; >= 19.0.0-next.0, < 19.2.25; <= 18.2.14; fixed in 21.2.16, 22.0.0-rc.2, 19.2.25, 20.3.24

## Suggested inspection (read-only)
- `npm ls @angular/platform-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @angular/platform-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gxx4-3xcv-f8qx (OSV record GHSA-gxx4-3xcv-f8qx lists affected ranges: npm @angular/platform-server >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14)
- Verified: https://github.com/advisories/GHSA-gxx4-3xcv-f8qx (GitHub-reviewed advisory GHSA-gxx4-3xcv-f8qx lists affected ranges: npm @angular/platform-server >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14)

Commands are suggestions: review each one before running it.

Loading voting…