@angular/platform-server: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE-2026-50555GHSA-hqr9-c56f-3x7f
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 22.0.0-next.0, < 22.0.0-rc.2>= 21.0.0-next.0, < 21.2.16>= 20.0.0-next.0, < 20.3.24>= 19.0.0-next.0, < 19.2.25<= 18.2.14
- Fixed in
- 21.2.16, 22.0.0-rc.2, 19.2.25, 20.3.24
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hqr9-c56f-3x7f lists affected ranges: npm @angular/platform-server >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hqr9-c56f-3x7f lists affected ranges: npm @angular/platform-server >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-50555: 0.27% estimated exploitation activity in the next 30 days; percentile 18.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A Cross-Site Scripting (XSS) vulnerability exists in @angular/platform-server's DOM emulation dependency (domino) when serializing the content of raw-text elements (such as <script, <style, and <iframe). domino supports escaping raw-text elements during serialization to prevent closing-tag breakout. However, a Unicode index alignment bug existed in this escaping logic. In JavaScript, string lengths and character indices are calculated based on UTF-16 code units (where astral characters—such as emojis—occupy 2 code units / 4 bytes). If the bound dynamic text contained astral Unicode characters before the closing tag (e.g. </script, </style, or </iframe), the index offset calculation in domino's replacement logic shifted. This misalignment caused domino to fail to replace or escape the closing tag, leaving it raw and unescaped in the output HTML. An attacker who controls the dynamic text can supply a payload containing both an astral Unicode character and a closing tag (e.g.,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-hqr9-c56f-3x7f
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-hqr9-c56f-3x7f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-50555
Advisory: @angular/platform-server: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
IDs: CVE-2026-50555, GHSA-hqr9-c56f-3x7f
Record: https://patchnext.com/advisories/cve-2026-50555 (revision 3, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: @angular/platform-server 22.0.0-rc.2, 21.2.16, 20.3.24, 19.2.25. A vendor fix does not mean a deployment is fixed.
## Affected components
- npm @angular/platform-server: affected >= 22.0.0-next.0, < 22.0.0-rc.2; >= 21.0.0-next.0, < 21.2.16; >= 20.0.0-next.0, < 20.3.24; >= 19.0.0-next.0, < 19.2.25; <= 18.2.14; fixed in 21.2.16, 22.0.0-rc.2, 19.2.25, 20.3.24
## Suggested inspection (read-only)
- `npm ls @angular/platform-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.
## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @angular/platform-server.
- Repeat the inspection and confirm that only fixed versions remain installed.
## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.
## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.
## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hqr9-c56f-3x7f (OSV record GHSA-hqr9-c56f-3x7f lists affected ranges: npm @angular/platform-server >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14)
- Verified: https://github.com/advisories/GHSA-hqr9-c56f-3x7f (GitHub-reviewed advisory GHSA-hqr9-c56f-3x7f lists affected ranges: npm @angular/platform-server >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14)
Commands are suggestions: review each one before running it.Loading voting…