Pomerium Pre-Auth Memory Exhaustion via Unbounded zstd Decompression in HPKE Callback
CVE-2026-50285GHSA-ggw3-5987-rx77
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/pomerium/pomerium 0.32.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/pomerium/pomerium
- Affected
- >= 0.32.6, < 0.32.8
- Fixed in
- 0.32.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-ggw3-5987-rx77 lists affected ranges: Go github.com/pomerium/pomerium >=0.32.6 <0.32.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-50285: 0.74% estimated exploitation activity in the next 30 days; percentile 54.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The HPKE V2 URL decode path in pkg/hpke/url.go decompresses attacker-controlled zstd data without any size limit. On Pomerium deployments using the stateless authentication flow (Pomerium Zero / hosted authenticate), the proxy's /.pomerium/callback endpoint is reachable without credentials and processes attacker-crafted HPKE-encrypted payloads before the sender's identity is validated. Because Pomerium's HPKE receiver public key is publicly served, an attacker can encrypt a decompression bomb, deliver it to the callback endpoint, and cause unbounded memory allocation — crashing or degrading the proxy process. Severity High (CVSS 3.1: 7.5) CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Attack Vector: Network — the /.pomerium/callback route on the proxy service is externally reachable. - Attack Complexity: Low — the receiver public key is publicly available at /.well-known/pomerium/hpke-public-key; no special conditions apply. - Privileges Required: None — the callback endpoint…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-ggw3-5987-rx77
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-50285 Advisory: Pomerium Pre-Auth Memory Exhaustion via Unbounded zstd Decompression in HPKE Callback IDs: CVE-2026-50285, GHSA-ggw3-5987-rx77 Record: https://patchnext.com/advisories/cve-2026-50285 (revision 1, source checked 26 Oct 2026, 15:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/pomerium/pomerium 0.32.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/pomerium/pomerium: affected >= 0.32.6, < 0.32.8; fixed in 0.32.8 ## Suggested inspection (read-only) - Go github.com/pomerium/pomerium: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/pomerium/pomerium. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-ggw3-5987-rx77 (GitHub-reviewed advisory GHSA-ggw3-5987-rx77 lists affected ranges: Go github.com/pomerium/pomerium >=0.32.6 <0.32.8) Commands are suggestions: review each one before running it.
Loading voting…