dd-trace-js: Improper parsing of W3C baggage headers may lead to DoS
CVE-2026-50272GHSA-wxqq-gcq8-c443
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dd-trace 5.100.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm dd-trace
- Affected
- < 5.100.0
- Fixed in
- 5.100.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wxqq-gcq8-c443 lists affected ranges: npm dd-trace >=0 <5.100.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wxqq-gcq8-c443 lists affected ranges: npm dd-trace >=0 <5.100.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-50272: 0.79% estimated exploitation activity in the next 30 days; percentile 56.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Datadog tracing libraries that implement W3C baggage propagation parse incoming baggage HTTP headers without enforcing item-count or byte-size limits on the extract path. The DDTRACEBAGGAGEMAXITEMS (default 64) and DDTRACEBAGGAGEMAXBYTES (default 8192) limits were applied only to baggage injection, not extraction. A remote, unauthenticated attacker can send a request whose baggage header contains an arbitrarily large number of comma-separated key-value pairs (or a single very large value). The tracer allocates a hash-map entry for each pair on every request, causing unbounded CPU and memory consumption and enabling a remote Denial of Service against any HTTP service that has the baggage propagation style enabled. The baggage propagation style is enabled by default in most affected tracers, so any internet-facing service that has been instrumented with an affected tracer version is exposed unless the propagation style has been explicitly narrowed. Patches This is resolved in…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-wxqq-gcq8-c443
- Revision 1 · created ·
Published from osv record GHSA-wxqq-gcq8-c443
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-50272 Advisory: dd-trace-js: Improper parsing of W3C baggage headers may lead to DoS IDs: CVE-2026-50272, GHSA-wxqq-gcq8-c443 Record: https://patchnext.com/advisories/cve-2026-50272 (revision 2, source checked 26 Oct 2026, 12:57 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dd-trace 5.100.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm dd-trace: affected < 5.100.0; fixed in 5.100.0 ## Suggested inspection (read-only) - `npm ls dd-trace --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dd-trace. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wxqq-gcq8-c443 (OSV record GHSA-wxqq-gcq8-c443 lists affected ranges: npm dd-trace >=0 <5.100.0 (fixed)) - Verified: https://github.com/advisories/GHSA-wxqq-gcq8-c443 (GitHub-reviewed advisory GHSA-wxqq-gcq8-c443 lists affected ranges: npm dd-trace >=0 <5.100.0) Commands are suggestions: review each one before running it.
Loading voting…