Steeltoe: OAEP setting silently selects PKCS#1 v1.5 padding
CVE-2026-50268GHSA-4j9m-h44m-2hv8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (steeltoe.configuration.encryption 4.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet steeltoe.configuration.encryption
- Affected
- >= 4.0.0, <= 4.1.0
- Fixed in
- 4.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4j9m-h44m-2hv8 lists affected ranges: NuGet steeltoe.configuration.encryption >=4.0.0 <=4.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 1.9 · CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-50268: 0.05% estimated exploitation activity in the next 30 days; percentile 0.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Configuring encrypt:rsa:algorithm=OAEP does not enable OAEP encryption. Due to an incorrect BouncyCastle transformation string, the OAEP setting selects PKCS#1 v1.5, which is the same algorithm as the DEFAULT setting. Impact Operators who configure encrypt:rsa:algorithm=OAEP to obtain CCA2-secure padding receive PKCS#1 v1.5 instead. Currently, Decrypt() is called only against operator-controlled configuration data, so no exploitable path exists, but any future code path that exposes a decryption oracle would be Bleichenbacher-vulnerable despite the OAEP setting. Migration note Existing {cipher} values produced under the broken OAEP setting were encrypted with PKCS#1 v1.5. The fix makes OAEP use actual OAEP padding, so those values will fail to decrypt after upgrading. Re-encrypt all affected {cipher} values after upgrading.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4j9m-h44m-2hv8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-50268 Advisory: Steeltoe: OAEP setting silently selects PKCS#1 v1.5 padding IDs: CVE-2026-50268, GHSA-4j9m-h44m-2hv8 Record: https://patchnext.com/advisories/cve-2026-50268 (revision 1, source checked 26 Oct 2026, 17:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: steeltoe.configuration.encryption 4.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet steeltoe.configuration.encryption: affected >= 4.0.0, <= 4.1.0; fixed in 4.2.0 ## Suggested inspection (read-only) - NuGet steeltoe.configuration.encryption: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on steeltoe.configuration.encryption. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4j9m-h44m-2hv8 (GitHub-reviewed advisory GHSA-4j9m-h44m-2hv8 lists affected ranges: NuGet steeltoe.configuration.encryption >=4.0.0 <=4.1.0) Commands are suggestions: review each one before running it.
Loading voting…