OpenStack Swift vulnerable to authenticated server-side request forgery
CVE-2026-50221GHSA-h8rc-w822-q8vq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (swift 2.37.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI swift
- Affected
- < 2.37.2
- Fixed in
- 2.37.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h8rc-w822-q8vq lists affected ranges: PyPI swift >=0 <2.37.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h8rc-w822-q8vq lists affected ranges: PyPI swift >=0 <2.37.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-50221: 0.22% estimated exploitation activity in the next 30 days; percentile 12.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In OpenStack Swift before 2.37.2, proxy-server does not strip internal update headers (X-Container-Host, X-Container-Device, X-Delete-At-Host, X-Delete-At-Device) from client requests before forwarding them to object-servers. An authenticated user with write access can inject these headers to redirect container update requests to an attacker-controlled server, enabling server-side request forgery. The SSRF requests expose internal cluster metadata including storage policy indexes, partition mappings, device names, and when at rest encryption is enabled, cipher text and initialization vectors for the container-level encryption key. The attacker can also cause "ghost listings" in arbitrary containers via the shard-range redirect mechanism.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-h8rc-w822-q8vq
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-h8rc-w822-q8vq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-50221 Advisory: OpenStack Swift vulnerable to authenticated server-side request forgery IDs: CVE-2026-50221, GHSA-h8rc-w822-q8vq Record: https://patchnext.com/advisories/cve-2026-50221 (revision 3, source checked 26 Oct 2026, 13:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: swift 2.37.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI swift: affected < 2.37.2; fixed in 2.37.2 ## Suggested inspection (read-only) - `python -m pip show swift`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on swift. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h8rc-w822-q8vq (OSV record GHSA-h8rc-w822-q8vq lists affected ranges: PyPI swift >=0 <2.37.2 (fixed)) - Verified: https://github.com/advisories/GHSA-h8rc-w822-q8vq (GitHub-reviewed advisory GHSA-h8rc-w822-q8vq lists affected ranges: PyPI swift >=0 <2.37.2) Commands are suggestions: review each one before running it.
Loading voting…