@angular/service-worker: Request Credential & Cache Policy Stripping
CVE-2026-50184GHSA-95qp-cmmw-mgqv
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 22.0.0-next.0, < 22.0.0-rc.2>= 21.0.0-next.0, < 21.2.15>= 20.0.0-next.0, < 20.3.22>= 19.0.0-next.0, < 19.2.23<= 18.2.14
- Fixed in
- 22.0.0-rc.2, 19.2.23, 20.3.22, 21.2.15
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-95qp-cmmw-mgqv lists affected ranges: npm @angular/service-worker >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-95qp-cmmw-mgqv lists affected ranges: npm @angular/service-worker >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.7 · CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-50184: 0.21% estimated exploitation activity in the next 30 days; percentile 10.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue in the @angular/service-worker package compromises the integrity of request-policy enforcement during request reconstruction. When the Angular Service Worker intercepts network requests for matched assets, it reconstructs a new Request object using an internal helper function. During this reconstruction process, the helper function strips explicit client-defined safety parameters: the credentials configuration (such as credentials: 'omit') and the HTTP cache mode configuration (such as cache: 'no-store'). These are reverted back to standard browser-default parameters (credentials: 'same-origin' and default HTTP cache properties). This causes the browser to include active credentials (such as cookies or Authorization headers) on outbound requests where the client-side developer explicitly instructed they should be omitted, leading to potential session leaks. Additionally, it causes private or non-cacheable resources to be cached by the service worker's engine, making private…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-95qp-cmmw-mgqv
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-95qp-cmmw-mgqv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-50184 Advisory: @angular/service-worker: Request Credential & Cache Policy Stripping IDs: CVE-2026-50184, GHSA-95qp-cmmw-mgqv Record: https://patchnext.com/advisories/cve-2026-50184 (revision 3, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: @angular/service-worker 22.0.0-rc.2, 21.2.15, 20.3.22, 19.2.23. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @angular/service-worker: affected >= 22.0.0-next.0, < 22.0.0-rc.2; >= 21.0.0-next.0, < 21.2.15; >= 20.0.0-next.0, < 20.3.22; >= 19.0.0-next.0, < 19.2.23; <= 18.2.14; fixed in 22.0.0-rc.2, 19.2.23, 20.3.22, 21.2.15 ## Suggested inspection (read-only) - `npm ls @angular/service-worker --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @angular/service-worker. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-95qp-cmmw-mgqv (OSV record GHSA-95qp-cmmw-mgqv lists affected ranges: npm @angular/service-worker >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14) - Verified: https://github.com/advisories/GHSA-95qp-cmmw-mgqv (GitHub-reviewed advisory GHSA-95qp-cmmw-mgqv lists affected ranges: npm @angular/service-worker >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14) Commands are suggestions: review each one before running it.
Loading voting…