Skip to content

← Actionable
High, CVSS 7.1amended

Langroid: Path traversal in the file tools allows read/write outside configured current directory

CVE-2026-50181GHSA-fg23-3346-88f5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langroid 0.64.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI langroid

    Affected
    <= 0.63.0
    Fixed in
    0.64.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-50181: 0.18% estimated exploitation activity in the next 30 days; percentile 8.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Langroid's ReadFileTool and WriteFileTool appear to treat currdir as the intended working-directory boundary for file operations. However, the tools only change the process working directory to currdir and then operate on the user-supplied filepath without resolving and enforcing that the final path remains inside currdir. As a result, a tool caller can supply path traversal sequences such as ../secret.txt to read files outside the configured current directory, or ../writtenbytool.txt to write files outside that directory. This can impact applications that expose Langroid file tools to an LLM agent, user-controlled tool call, or delegated coding/documentation agent while relying on currdir to restrict file access to a project/workspace directory. Details Affected components: - langroid/agent/tools/filetools.py - langroid/utils/system.py Relevant behavior observed: ReadFileTool contains a comment indicating the intended assumption: text ASSUME: filepath should be relative to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fg23-3346-88f5

  2. Revision 1 · created ·

    Published from osv record GHSA-fg23-3346-88f5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-50181

Advisory: Langroid: Path traversal in the file tools allows read/write outside configured current directory
IDs: CVE-2026-50181, GHSA-fg23-3346-88f5
Record: https://patchnext.com/advisories/cve-2026-50181 (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langroid 0.64.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langroid: affected <= 0.63.0; fixed in 0.64.0

## Suggested inspection (read-only)
- `python -m pip show langroid`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langroid.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fg23-3346-88f5 (OSV record GHSA-fg23-3346-88f5 lists affected ranges: PyPI langroid >=0 <0.64.0 (fixed))
- Verified: https://github.com/advisories/GHSA-fg23-3346-88f5 (GitHub-reviewed advisory GHSA-fg23-3346-88f5 lists affected ranges: PyPI langroid >=0 <=0.63.0)

Commands are suggestions: review each one before running it.

Loading voting…