@angular/common: Denial of Service (DoS) via OOM in Number Formatting (digitsInfo)
CVE-2026-50171GHSA-p3vc-36g9-x9gr
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @angular/common
- Affected
- >= 22.0.0-next.0, < 22.0.0-rc.2>= 20.0.0-next.0, < 20.3.22>= 19.0.0-next.0, < 19.2.23<= 18.2.14>= 21.0.0-next.0, < 21.2.15
- Fixed in
- 22.0.0-rc.2, 19.2.23, 20.3.22, 21.2.15
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p3vc-36g9-x9gr lists affected ranges: npm @angular/common >=22.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 =21.0.0-next.0 <21.2.15 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p3vc-36g9-x9gr lists affected ranges: npm @angular/common >=22.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 =21.0.0-next.0 <21.2.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-50171: 0.26% estimated exploitation activity in the next 30 days; percentile 17.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A Denial of Service (DoS) vulnerability exists in the @angular/common package of Angular. The formatNumber function, which is also utilized by DecimalPipe, PercentPipe, and CurrencyPipe, does not properly validate the upper bounds of the digitsInfo parameter. Specifically, the minimum and maximum fraction digits parsed from the digitsInfo string (e.g., 1.2-4) are converted to integers and used without limits. When parsing a maliciously crafted digitsInfo string with excessively large fraction digit values (e.g., 1.200000000-200000000), the internal roundNumber function attempts to pad the digits array to match the requested fraction size. This results in an unbounded loop that repeatedly pushes elements into an array. Impact Successful exploitation of this vulnerability allows an attacker to trigger resource exhaustion, leading to a Denial of Service (DoS): Server-Side Rendering (SSR): In applications using SSR (e.g., @angular/ssr), an attacker can crash the Node.js server process…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-p3vc-36g9-x9gr
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-p3vc-36g9-x9gr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-50171 Advisory: @angular/common: Denial of Service (DoS) via OOM in Number Formatting (digitsInfo) IDs: CVE-2026-50171, GHSA-p3vc-36g9-x9gr Record: https://patchnext.com/advisories/cve-2026-50171 (revision 3, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: @angular/common 22.0.0-rc.2, 21.2.15, 20.3.22, 19.2.23. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @angular/common: affected >= 22.0.0-next.0, < 22.0.0-rc.2; >= 20.0.0-next.0, < 20.3.22; >= 19.0.0-next.0, < 19.2.23; <= 18.2.14; >= 21.0.0-next.0, < 21.2.15; fixed in 22.0.0-rc.2, 19.2.23, 20.3.22, 21.2.15 ## Suggested inspection (read-only) - `npm ls @angular/common --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @angular/common. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p3vc-36g9-x9gr (OSV record GHSA-p3vc-36g9-x9gr lists affected ranges: npm @angular/common >=22.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 =21.0.0-next.0 <21.2.15 (fixed)) - Verified: https://github.com/advisories/GHSA-p3vc-36g9-x9gr (GitHub-reviewed advisory GHSA-p3vc-36g9-x9gr lists affected ranges: npm @angular/common >=22.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 =21.0.0-next.0 <21.2.15) Commands are suggestions: review each one before running it.
Loading voting…