Mermaid allows CSS injection applying to sibling elements of the diagram
CVE-2026-50159GHSA-6x64-9x62-f2gx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mermaid 11.16.1, 10.9.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm mermaid
- Affected
- >= 11.0.0-alpha.1, < 11.16.1< 10.9.8
- Fixed in
- 10.9.8, 11.16.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6x64-9x62-f2gx lists affected ranges: npm mermaid >=11.0.0-alpha.1 =0 <10.9.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:L · score source
- EPSS
- CVE-2026-50159: 0.60% estimated exploitation activity in the next 30 days; percentile 48.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Mermaid does not fully restrict CSS to the rendered SVG subtree. Although selectors are prefixed with #mermaid-X, sibling (~ and +) combinators can still escape the Mermaid container and inject styles to DOM elements adjacent to the diagram <svg. Most users of mermaid would not be affected by this, as mermaid adds its <svg as an only child of it's parent element. However, you may be affected if you manually insert the <svg (or other elements) into the DOM yourself. Details Mermaid namespaces CSS through with a middleware intended to scope all rules to the diagram's SVG element. CSS nesting expands & ~ { ... } to #svgId ~ , which selects all sibling elements following the SVG in the DOM, outside the diagram boundary. Impact An attacker able to supply diagram source to a page (e.g., user-generated content rendered by Mermaid) could inject CSS rules affecting sibling elements to the diagram <svg on the host page. This can be used for UI redressing, hiding content, conditional…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6x64-9x62-f2gx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-50159 Advisory: Mermaid allows CSS injection applying to sibling elements of the diagram IDs: CVE-2026-50159, GHSA-6x64-9x62-f2gx Record: https://patchnext.com/advisories/cve-2026-50159 (revision 1, source checked 26 Oct 2026, 13:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mermaid 11.16.1, 10.9.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm mermaid: affected >= 11.0.0-alpha.1, < 11.16.1; < 10.9.8; fixed in 10.9.8, 11.16.1 ## Suggested inspection (read-only) - `npm ls mermaid --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mermaid. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6x64-9x62-f2gx (GitHub-reviewed advisory GHSA-6x64-9x62-f2gx lists affected ranges: npm mermaid >=11.0.0-alpha.1 =0 <10.9.8) Commands are suggestions: review each one before running it.
Loading voting…