Auth0 Symfony SDK Accepted Bearer Tokens via URL Query Parameter
CVE-2026-50157GHSA-ffq7-hh2j-r24p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (auth0/symfony 5.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist auth0/symfony
- Affected
- >= 5.0.0-BETA0, <= 5.8.0
- Fixed in
- 5.9.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-ffq7-hh2j-r24p lists affected ranges: Packagist auth0/symfony >=5.0.0-BETA0 <=5.8.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-50157: 0.51% estimated exploitation activity in the next 30 days; percentile 43.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description Applications built with the Auth0 Symphony SDK, using the Authorizer security authenticator to protect HTTP routes may accept OAuth 2.0 bearer access tokens provided through a URL query parameter, in addition to the standard Authorization header, which may increase the risk of access token exposure and replay against protected API endpoints. Resolution Upgrade auth0/symfony to version 5.9.0 or greater. Acknowledgement Okta would like to thank Alex Yeara for their discovery.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-ffq7-hh2j-r24p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-50157 Advisory: Auth0 Symfony SDK Accepted Bearer Tokens via URL Query Parameter IDs: CVE-2026-50157, GHSA-ffq7-hh2j-r24p Record: https://patchnext.com/advisories/cve-2026-50157 (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: auth0/symfony 5.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist auth0/symfony: affected >= 5.0.0-BETA0, <= 5.8.0; fixed in 5.9.0 ## Suggested inspection (read-only) - Packagist auth0/symfony: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on auth0/symfony. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-ffq7-hh2j-r24p (GitHub-reviewed advisory GHSA-ffq7-hh2j-r24p lists affected ranges: Packagist auth0/symfony >=5.0.0-BETA0 <=5.8.0) Commands are suggestions: review each one before running it.
Loading voting…