Skip to content

← Actionable
High, CVSS 7.3amended

Budibase has an Account Impersonation Issue — Chat Identity Link Hijacking via Missing Consent & CSRF

CVE-2026-50132GHSA-v7j5-vc4m-723w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@budibase/server 3.39.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-50132: 0.19% estimated exploitation activity in the next 30 days; percentile 8.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Title Chat Identity Link Hijacking — Attacker Can Silently Map Their Slack/Discord Identity to Any Authenticated Budibase User's Account Severity High — CVSS 3.1: AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N = 7.3 Affected Product - Product: Budibase - Version: 3.37.2 (introduced in this version) - Component: packages/server/src/api/controllers/ai/chatIdentityLinks.ts - Endpoint: GET /api/chat-links/:instance/:token/handoff Vulnerability Type - CWE-352: Cross-Site Request Forgery - CWE-284: Improper Access Control --- Vulnerability Description GET /api/chat-links/:instance/:token/handoff is a public endpoint (no auth required) that performs a permanent, state-changing operation: it binds an external chat identity (Slack/Discord/MS Teams) to an authenticated Budibase user account, with no consent UI and no CSRF protection. The session token in the URL is created by the attacker (from their own /link slash command) and embeds the attacker's externalUserId. When an authenticated Budibase victim…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v7j5-vc4m-723w

  2. Revision 1 · created ·

    Published from osv record GHSA-v7j5-vc4m-723w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-50132

Advisory: Budibase has an Account Impersonation Issue — Chat Identity Link Hijacking via Missing Consent & CSRF
IDs: CVE-2026-50132, GHSA-v7j5-vc4m-723w
Record: https://patchnext.com/advisories/cve-2026-50132 (revision 2, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @budibase/server 3.39.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @budibase/server: affected < 3.39.0; fixed in 3.39.0

## Suggested inspection (read-only)
- `npm ls @budibase/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @budibase/server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v7j5-vc4m-723w (OSV record GHSA-v7j5-vc4m-723w lists affected ranges: npm @budibase/server >=0 <3.39.0 (fixed))
- Verified: https://github.com/advisories/GHSA-v7j5-vc4m-723w (GitHub-reviewed advisory GHSA-v7j5-vc4m-723w lists affected ranges: npm @budibase/server >=0 <3.39.0)

Commands are suggestions: review each one before running it.

Loading voting…