Skip to content

← Actionable
Critical, CVSS 9.1

Apache Fory Java SDK Has Deserialization of Untrusted Data in the Java replace-resolve path

CVE-2026-50076GHSA-8f39-v287-78jf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.fory:fory-core 1.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-50076: 0.52% estimated exploitation activity in the next 30 days; percentile 44.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Deserialization of Untrusted Data in the Java replace-resolve path in Apache Fory fory-core Java SDK before 1.1.0 on Java/JVM platforms allows a remote attacker to bypass class registration, TypeChecker, and DisallowedList checks and invoke classpath-present readResolve/readExternal hooks via crafted Fory serialized data. Users are recommended to upgrade to version 1.1.0 or later, which fixes this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8f39-v287-78jf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-50076

Advisory: Apache Fory Java SDK Has Deserialization of Untrusted Data in the Java replace-resolve path
IDs: CVE-2026-50076, GHSA-8f39-v287-78jf
Record: https://patchnext.com/advisories/cve-2026-50076 (revision 1, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.fory:fory-core 1.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.fory:fory-core: affected < 1.1.0; fixed in 1.1.0

## Suggested inspection (read-only)
- Maven org.apache.fory:fory-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.fory:fory-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8f39-v287-78jf (GitHub-reviewed advisory GHSA-8f39-v287-78jf lists affected ranges: Maven org.apache.fory:fory-core >=0 <1.1.0)

Commands are suggestions: review each one before running it.

Loading voting…