Skip to content

← Actionable
High, CVSS 8.3amended

yt-dlp: Dangerous file type creation via insufficient filename sanitization (Bypass of CVE-2024-38519)

CVE-2026-50023GHSA-c6mh-fpjc-4pr3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (yt-dlp 2026.6.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI yt-dlp

    Affected
    < 2026.6.9
    Fixed in
    2026.6.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.3 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-50023: 0.66% estimated exploitation activity in the next 30 days; percentile 51.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A vulnerability exists in yt-dlp that allows a remote attacker to write arbitrary OS-shortcut files (such as .desktop, .url, .webloc) to the user's filesystem, bypassing the remediation for CVE-2024-38519. Details The fix for CVE-2024-38519 enforced an allowlist for file extensions, in order to prevent writing files with unsafe extensions (such as .exe or .sh) during file downloads. However, this allowlist explicitly included the unsafe extensions .desktop, .url, and .webloc so that the functionality of the --write-link option (and its variants) could be preserved. These allowlist inclusions can be exploited by an attacker to write malicious OS-shortcut files in the context of a media or subtitles download. Numerous yt-dlp extractors derive the downloaded media or subtitles file extension from a potentially attacker-controlled source. An attacker could craft an m3u8 file that contains an EXT-X-MEDIA:TYPE=SUBTITLES tag with a malicious URI (e.g.,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-c6mh-fpjc-4pr3

  2. Revision 1 · created ·

    Published from osv record GHSA-c6mh-fpjc-4pr3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-50023

Advisory: yt-dlp: Dangerous file type creation via insufficient filename sanitization (Bypass of CVE-2024-38519)
IDs: CVE-2026-50023, GHSA-c6mh-fpjc-4pr3
Record: https://patchnext.com/advisories/cve-2026-50023 (revision 2, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: yt-dlp 2026.6.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI yt-dlp: affected < 2026.6.9; fixed in 2026.6.9

## Suggested inspection (read-only)
- `python -m pip show yt-dlp`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on yt-dlp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c6mh-fpjc-4pr3 (OSV record GHSA-c6mh-fpjc-4pr3 lists affected ranges: PyPI yt-dlp >=0 <2026.6.9 (fixed))
- Verified: https://github.com/advisories/GHSA-c6mh-fpjc-4pr3 (GitHub-reviewed advisory GHSA-c6mh-fpjc-4pr3 lists affected ranges: PyPI yt-dlp >=0 <2026.6.9)

Commands are suggestions: review each one before running it.

Loading voting…