pnpm Has an Integrity Check Bypass via Missing Lockfile Integrity Field
CVE-2026-50021GHSA-q6j5-fjx5-2mc3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pnpm 11.4.0, 10.34.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm pnpm
- Affected
- >= 11.0.0, < 11.4.0< 10.34.1
- Fixed in
- 11.4.0, 10.34.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q6j5-fjx5-2mc3 lists affected ranges: npm pnpm >=11.0.0 =0 <10.34.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q6j5-fjx5-2mc3 lists affected ranges: npm pnpm >=11.0.0 =0 <10.34.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-50021: 0.18% estimated exploitation activity in the next 30 days; percentile 7.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary pnpm's tarball extraction worker skips integrity verification when the integrity field is absent from the lockfile resolution. If an attacker can both modify pnpm-lock.yaml to remove the integrity: field and cause the referenced registry URL to serve altered package content, pnpm install --frozen-lockfile can install the altered package without an integrity error. npm's npm ci enforces integrity by default; pnpm's behavior of silently skipping verification is a pnpm-specific fail-open gap. Vulnerability Details The addTarballToStore function in worker/src/start.ts (lines 189-204) checks if (integrity) before verifying the tarball hash. The TarballResolution type declares integrity as optional (integrity?: string). When the lockfile omits the integrity field, the guard evaluates to false, skipping hash verification entirely. The worker then computes a new hash from the unverified content and stores it as legitimate. Proof of Concept Impact Supply chain compromise in…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-q6j5-fjx5-2mc3
- Revision 1 · created ·
Published from osv record GHSA-q6j5-fjx5-2mc3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-50021 Advisory: pnpm Has an Integrity Check Bypass via Missing Lockfile Integrity Field IDs: CVE-2026-50021, GHSA-q6j5-fjx5-2mc3 Record: https://patchnext.com/advisories/cve-2026-50021 (revision 2, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pnpm 11.4.0, 10.34.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm pnpm: affected >= 11.0.0, < 11.4.0; < 10.34.1; fixed in 11.4.0, 10.34.1 ## Suggested inspection (read-only) - `npm ls pnpm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pnpm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q6j5-fjx5-2mc3 (OSV record GHSA-q6j5-fjx5-2mc3 lists affected ranges: npm pnpm >=11.0.0 =0 <10.34.1 (fixed)) - Verified: https://github.com/advisories/GHSA-q6j5-fjx5-2mc3 (GitHub-reviewed advisory GHSA-q6j5-fjx5-2mc3 lists affected ranges: npm pnpm >=11.0.0 =0 <10.34.1) Commands are suggestions: review each one before running it.
Loading voting…