Skip to content

← Actionable
Medium, CVSS 6.9amended

pnpm binds unscoped user-level npm auth credentials to a repository-selected registry

CVE-2026-50017GHSA-cjhr-43r9-cfmw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pnpm 11.4.0, 10.34.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm pnpm

    Affected
    < 10.34.0>= 11.0.0, < 11.4.0
    Fixed in
    10.34.0, 11.4.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-50017: 0.44% estimated exploitation activity in the next 30 days; percentile 38.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary pnpm can send user-level unscoped npm authentication credentials to a registry chosen by a repository-local .npmrc file. In the reproduced case, the user's npm config contains a default registry and an unscoped authToken. The repository does not provide a token-bearing auth line. It only sets registry= to a different registry URL. During normal pnpm metadata/install workflows, pnpm binds the user-origin unscoped credential to the repository-selected registry and sends it as an Authorization header. This was reproduced with fake credentials and loopback registries only. No third-party registry or real token was used. Affected Behavior Observed Observed affected: - pnpm 10.33.2: pnpm install --ignore-scripts sends the user-level unscoped authToken to the repository-selected registry. - pnpm 11.1.3: pnpm install --ignore-scripts sends the user-level unscoped authToken to the repository-selected registry. - pnpm 11.2.1 (next-11 dist tag at testing time): pnpm install…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-cjhr-43r9-cfmw

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-cjhr-43r9-cfmw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-50017

Advisory: pnpm binds unscoped user-level npm auth credentials to a repository-selected registry
IDs: CVE-2026-50017, GHSA-cjhr-43r9-cfmw
Record: https://patchnext.com/advisories/cve-2026-50017 (revision 3, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pnpm 11.4.0, 10.34.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm pnpm: affected < 10.34.0; >= 11.0.0, < 11.4.0; fixed in 10.34.0, 11.4.0

## Suggested inspection (read-only)
- `npm ls pnpm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pnpm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cjhr-43r9-cfmw (OSV record GHSA-cjhr-43r9-cfmw lists affected ranges: npm pnpm >=0 =11.0.0 <11.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-cjhr-43r9-cfmw (GitHub-reviewed advisory GHSA-cjhr-43r9-cfmw lists affected ranges: npm pnpm >=0 =11.0.0 <11.4.0)

Commands are suggestions: review each one before running it.

Loading voting…