Skip to content

← Actionable
Medium, CVSS 6.4amended

pnpm: Git Fetch Argument Injection via Lockfile resolution.commit

CVE-2026-50014GHSA-p4xf-rf54-rj3x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pnpm 11.4.0, 10.34.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm pnpm

    Affected
    < 10.34.0>= 11.0.0, < 11.4.0
    Fixed in
    10.34.0, 11.4.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.4 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-50014: 0.32% estimated exploitation activity in the next 30 days; percentile 24.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary pnpm passes the lockfile-controlled git resolution.commit value to git fetch without a -- separator or commit-format validation. For git dependencies fetched through the shallow-fetch path, a malicious lockfile can replace the expected 40-character commit hash with a Git option such as --upload-pack=<command. For SSH and local transports, --upload-pack can execute the supplied command. HTTPS transports ignore --upload-pack, so the practical attack surface is primarily SSH or local git dependencies. Vulnerability Details The vulnerable path is in fetching/git-fetcher/src/index.ts. When a git dependency host is configured for shallow fetching, pnpm calls: Because resolution.commit is appended before a -- separator, Git can parse a commit value beginning with - as an option. The same file later passes the value to git checkout without a separator: resolution.commit comes from the lockfile and is typed as a plain string; pnpm does not validate it as a 40-character hexadecimal…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-p4xf-rf54-rj3x

  2. Revision 1 · created ·

    Published from osv record GHSA-p4xf-rf54-rj3x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-50014

Advisory: pnpm: Git Fetch Argument Injection via Lockfile resolution.commit
IDs: CVE-2026-50014, GHSA-p4xf-rf54-rj3x
Record: https://patchnext.com/advisories/cve-2026-50014 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pnpm 11.4.0, 10.34.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm pnpm: affected < 10.34.0; >= 11.0.0, < 11.4.0; fixed in 10.34.0, 11.4.0

## Suggested inspection (read-only)
- `npm ls pnpm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pnpm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p4xf-rf54-rj3x (OSV record GHSA-p4xf-rf54-rj3x lists affected ranges: npm pnpm >=0 =11.0.0 <11.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-p4xf-rf54-rj3x (GitHub-reviewed advisory GHSA-p4xf-rf54-rj3x lists affected ranges: npm pnpm >=0 =11.0.0 <11.4.0)

Commands are suggestions: review each one before running it.

Loading voting…