Skip to content

← Actionable
High, CVSS 7.5

Netty: Wrapping plain trust manager silently disables hostname verification

CVE-2026-50010GHSA-c653-97m9-rcg9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-handler 4.2.15.Final, 4.1.135.Final), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven io.netty:netty-handler

    Affected
    >= 4.2.0.Final, < 4.2.15.Final<= 4.1.134.Final
    Fixed in
    4.2.15.Final, 4.1.135.Final

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-50010: 0.49% estimated exploitation activity in the next 30 days; percentile 42.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

SimpleTrustManagerFactory.engineGetTrustManagers() and related paths wrap any user-supplied plain X509TrustManager in X509TrustManagerWrapper, which extends X509ExtendedTrustManager but implements the 3-arg checkServerTrusted(chain, authType, SSLEngine) by discarding the SSLEngine and calling the 2-arg delegate. Because the object now IS an X509ExtendedTrustManager, neither SunJSSE's internal AbstractTrustManagerWrapper nor Netty's own OpenSslX509TrustManagerWrapper will re-wrap it to add endpoint-identification. Consequently, even though Netty 4.2 sets endpointIdentificationAlgorithm="HTTPS" by default, a client built with SslContextBuilder.forClient().trustManager(somePlainX509TrustManager) performs no hostname verification at all.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-c653-97m9-rcg9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-50010

Advisory: Netty: Wrapping plain trust manager silently disables hostname verification
IDs: CVE-2026-50010, GHSA-c653-97m9-rcg9
Record: https://patchnext.com/advisories/cve-2026-50010 (revision 1, source checked 26 Oct 2026, 16:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-handler 4.2.15.Final, 4.1.135.Final. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.netty:netty-handler: affected >= 4.2.0.Final, < 4.2.15.Final; <= 4.1.134.Final; fixed in 4.2.15.Final, 4.1.135.Final

## Suggested inspection (read-only)
- Maven io.netty:netty-handler: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.netty:netty-handler.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c653-97m9-rcg9 (GitHub-reviewed advisory GHSA-c653-97m9-rcg9 lists affected ranges: Maven io.netty:netty-handler >=4.2.0.Final =0 <=4.1.134.Final)

Commands are suggestions: review each one before running it.

Loading voting…