parse-server: Server option routeAllowList is bypassable through batch sub-requests
CVE-2026-50008GHSA-p84r-h6rx-f2xr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.9.1-alpha.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse-server
- Affected
- >= 9.8.0, < 9.9.1-alpha.3
- Fixed in
- 9.9.1-alpha.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p84r-h6rx-f2xr lists affected ranges: npm parse-server >=9.8.0 <9.9.1-alpha.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p84r-h6rx-f2xr lists affected ranges: npm parse-server >=9.8.0 <9.9.1-alpha.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-50008: 0.34% estimated exploitation activity in the next 30 days; percentile 27.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The routeAllowList server option restricts external client access to a configured list of REST API routes. The check is only enforced as Express middleware against the outer HTTP request URL, so the /batch handler dispatches each sub-request to the internal router without re-running the allow-list check. An external caller whose outer route matches batch can issue batch sub-requests to any REST API route that the operator omitted from the allow-list. Authentication, ACL, CLP, and other inner-route authorization controls still apply — only the operator-configured route firewall is bypassed. Patches routeAllowList is now re-enforced for each batch sub-request inside the batch handler before dispatch, mirroring the existing per-sub-request rate-limit enforcement pattern. The path-normalization and regex-match logic was extracted into a shared helper used by both the outer middleware and the batch handler. Master and maintenance keys bypass the per-sub-request check on the same…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-p84r-h6rx-f2xr
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-p84r-h6rx-f2xr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-50008 Advisory: parse-server: Server option routeAllowList is bypassable through batch sub-requests IDs: CVE-2026-50008, GHSA-p84r-h6rx-f2xr Record: https://patchnext.com/advisories/cve-2026-50008 (revision 3, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse-server 9.9.1-alpha.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse-server: affected >= 9.8.0, < 9.9.1-alpha.3; fixed in 9.9.1-alpha.3 ## Suggested inspection (read-only) - `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p84r-h6rx-f2xr (OSV record GHSA-p84r-h6rx-f2xr lists affected ranges: npm parse-server >=9.8.0 <9.9.1-alpha.3 (fixed)) - Verified: https://github.com/advisories/GHSA-p84r-h6rx-f2xr (GitHub-reviewed advisory GHSA-p84r-h6rx-f2xr lists affected ranges: npm parse-server >=9.8.0 <9.9.1-alpha.3) Commands are suggestions: review each one before running it.
Loading voting…