Skip to content

← Actionable
Medium, CVSS 6.3

Kimai: Login CSRF in Default Team Creation Endpoints Allows Unauthorized Team and Permission Structure Changes

CVE-2026-49992GHSA-pgcc-vfmc-7cw5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (kimai/kimai 2.58.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-49992: 0.22% estimated exploitation activity in the next 30 days; percentile 12.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Kimai 2.56.0 contains authenticated cross-site request forgery issues in its default team creation shortcuts for projects, customers, and activities. These endpoints are exposed through GET routes and directly create or reuse a Team, add the current user as teamlead, and bind the target object to that team. As a result, an attacker can trick a logged-in user with the required permissions into visiting a malicious page and cause unauthorized changes to team, teamlead, and object-binding relationships. This is a real authorization-structure modification issue rather than a harmless UI shortcut. Details The issue affects at least the following routes: - GET /en/admin/project/{id}/createteam - GET /en/admin/customer/{id}/createteam - GET /en/admin/activity/{id}/createteam Each of these routes is a GET endpoint, yet each performs persistent writes that alter authorization structure: - create or reuse a Team - add the current user as teamlead - bind the target Project, Customer, or…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pgcc-vfmc-7cw5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49992

Advisory: Kimai: Login CSRF in Default Team Creation Endpoints Allows Unauthorized Team and Permission Structure Changes
IDs: CVE-2026-49992, GHSA-pgcc-vfmc-7cw5
Record: https://patchnext.com/advisories/cve-2026-49992 (revision 1, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: kimai/kimai 2.58.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist kimai/kimai: affected <= 2.57.0; fixed in 2.58.0

## Suggested inspection (read-only)
- Packagist kimai/kimai: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on kimai/kimai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pgcc-vfmc-7cw5 (GitHub-reviewed advisory GHSA-pgcc-vfmc-7cw5 lists affected ranges: Packagist kimai/kimai >=0 <=2.57.0)

Commands are suggestions: review each one before running it.

Loading voting…