Skip to content

← Actionable
Unrated

CrateDB's Blob HTTP handler bypasses authorization

CVE-2026-49989GHSA-2xv8-gjwh-fv8p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.crate:crate 6.3.2, 6.2.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven io.crate:crate

    Affected
    < 6.2.8>= 6.3.0, < 6.3.2
    Fixed in
    6.3.2, 6.2.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2026-49989: 0.47% estimated exploitation activity in the next 30 days; percentile 40.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Component: io.crate.protocols.http.HttpBlobHandler Affected: verified against CrateDB 6.2.7 (latest at time of report; the bug has existed since the blob HTTP handler was introduced) Impact: any authenticated user can read or delete any blob whose SHA-1 digest they know, and can plant new blobs unconditionally, in any blob table, regardless of GRANTs. --- Summary CrateDB has two ways to access blob storage: SQL (SELECT ... FROM blob.<table and friends) and the blob HTTP API (GET|PUT|DELETE /blobs/{table}/{digest}). The SQL path goes through AccessControl, which is what enforces privilege grants; that's why SELECT digest FROM blob.secretblobs fails for a user who has no grants on the table. The HTTP path authenticates the request but never asks AccessControl whether the authenticated user is allowed to touch the table. So a user with no grants gets MissingPrivilegeException from SQL and 200 OK plus the blob bytes from GET /blobs/secretblobs/<digest. Where it lives…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2xv8-gjwh-fv8p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49989

Advisory: CrateDB's Blob HTTP handler bypasses authorization
IDs: CVE-2026-49989, GHSA-2xv8-gjwh-fv8p
Record: https://patchnext.com/advisories/cve-2026-49989 (revision 1, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.crate:crate 6.3.2, 6.2.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.crate:crate: affected < 6.2.8; >= 6.3.0, < 6.3.2; fixed in 6.3.2, 6.2.8

## Suggested inspection (read-only)
- Maven io.crate:crate: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.crate:crate.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2xv8-gjwh-fv8p (GitHub-reviewed advisory GHSA-2xv8-gjwh-fv8p lists affected ranges: Maven io.crate:crate >=0 =6.3.0 <6.3.2)

Commands are suggestions: review each one before running it.

Loading voting…