Skip to content

← Actionable
High, CVSS 8.8amended

repomix Vulnerable to Command Injection (RCE) via --remote-branch Argument Injection

CVE-2026-49987GHSA-9mm9-rqhj-j5mx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (repomix 1.14.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm repomix

    Affected
    < 1.14.1
    Fixed in
    1.14.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-49987: 0.70% estimated exploitation activity in the next 30 days; percentile 53.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vulnerability Metadata | Field | Detail | | --- | --- | | Affected Component | src/core/git/gitCommand.ts (execGitShallowClone) | | Impact | Arbitrary Command Execution / Security Control Bypass | Summary The --remote-branch CLI option in repomix is vulnerable to argument injection. User-supplied input is passed directly to git fetch and git checkout subprocesses via childprocess.execFileAsync without sanitization, -- delimiters, or validation. An attacker can inject arbitrary git command-line options. By injecting the --upload-pack option and specifying an SSH (git@...) or local (file://) remote URL, an attacker achieves arbitrary command execution with the privileges of the user running repomix. This bypasses the existing dangerousParams blocklist implemented in validateGitUrl(). Vulnerable Code Analysis File: src/core/git/gitCommand.ts The remoteBranch parameter is appended directly to the arguments array for git subprocesses without the -- positional delimiter. Sink 1 (Lines…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9mm9-rqhj-j5mx

  2. Revision 1 · created ·

    Published from osv record GHSA-9mm9-rqhj-j5mx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49987

Advisory: repomix Vulnerable to Command Injection (RCE) via `--remote-branch` Argument Injection
IDs: CVE-2026-49987, GHSA-9mm9-rqhj-j5mx
Record: https://patchnext.com/advisories/cve-2026-49987 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: repomix 1.14.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm repomix: affected < 1.14.1; fixed in 1.14.1

## Suggested inspection (read-only)
- `npm ls repomix --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on repomix.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9mm9-rqhj-j5mx (OSV record GHSA-9mm9-rqhj-j5mx lists affected ranges: npm repomix >=0 <1.14.1 (fixed))
- Verified: https://github.com/advisories/GHSA-9mm9-rqhj-j5mx (GitHub-reviewed advisory GHSA-9mm9-rqhj-j5mx lists affected ranges: npm repomix >=0 <1.14.1)

Commands are suggestions: review each one before running it.

Loading voting…