Skip to content

← Actionable
Critical, CVSS 9.8amended

Rclone: Unauthenticated command execution in rclone rcd --rc-serve via inline remote instantiation, bypassing CVE-2026-41179 fix

CVE-2026-49980GHSA-qw24-gh76-8rvv

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/ncw/rclone

    Affected
    >= 1.46.0
    Fixed in
    no fixed version recorded
  • Go github.com/rclone/rclone

    Affected
    >= 1.46.0, <= 1.74.2
    Fixed in
    1.74.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-49980: 0.78% estimated exploitation activity in the next 30 days; percentile 55.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary rclone rcd --rc-serve accepts unauthenticated GET and HEAD requests to paths of the form: The remote value is parsed from the URL and passed to normal backend initialization. Inline remote configuration can set backend options that execute local commands during initialization. As a result, a single unauthenticated GET or HEAD request can execute a command as the rclone process user. Versions from 1.55.0 onwards are vulnerable to command execution. Earlier versions (from 1.46.0) are vulnerable to the unauthenticated local file read described under "Additional impact" but not to command execution, because inline backend option overrides did not exist until 1.55.0. Preconditions Preconditions for this vulnerability are: - The rclone remote control API must be enabled, either by the --rc flag or by running the rclone rcd server - The remote control API must be reachable by the attacker - by default rclone only serves the rc to localhost unless the --rc-addr flag is in use - The…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-qw24-gh76-8rvv

  2. Revision 1 · created ·

    Published from osv record GO-2026-5596

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49980

Advisory: Rclone: Unauthenticated command execution in `rclone rcd --rc-serve` via inline remote instantiation, bypassing CVE-2026-41179 fix
IDs: CVE-2026-49980, GHSA-qw24-gh76-8rvv
Record: https://patchnext.com/advisories/cve-2026-49980 (revision 2, source checked 26 Oct 2026, 15:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: github.com/rclone/rclone 1.74.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/ncw/rclone: affected >= 1.46.0
- Go github.com/rclone/rclone: affected >= 1.46.0, <= 1.74.2; fixed in 1.74.3

## Suggested inspection (read-only)
- Go github.com/ncw/rclone: check the installed version with your package manager.
- Go github.com/rclone/rclone: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/ncw/rclone, github.com/rclone/rclone.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GO-2026-5596 (OSV record GO-2026-5596 lists affected ranges: Go github.com/rclone/rclone >=1.49.0 =1.46.0)
- Verified: https://github.com/advisories/GHSA-qw24-gh76-8rvv (GitHub-reviewed advisory GHSA-qw24-gh76-8rvv lists affected ranges: Go github.com/rclone/rclone >=1.46.0 <=1.74.2)

Commands are suggestions: review each one before running it.

Loading voting…