Apache ActiveMQ Improper Authorization vulnerability
CVE-2026-49877GHSA-f892-4h9f-j7g9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.activemq:apache-activemq 6.2.7, 5.19.8; activemq 6.2.7, 5.19.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.activemq:apache-activemq
- Affected
- < 5.19.8>= 6.0.0, < 6.2.7
- Fixed in
- 5.19.8, 6.2.7
Bitnami activemq
- Affected
- < 5.19.8>= 6.0.0, < 6.2.7
- Fixed in
- 5.19.8, 6.2.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f892-4h9f-j7g9 lists affected ranges: Maven org.apache.activemq:apache-activemq >=0 =6.0.0 <6.2.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-activemq-2026-49877 lists affected ranges: Bitnami activemq >=0 =6.0.0 <6.2.7 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f892-4h9f-j7g9 lists affected ranges: Maven org.apache.activemq:apache-activemq >=0 =6.0.0 <6.2.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-49877: 0.51% estimated exploitation activity in the next 30 days; percentile 43.90 (FIRST EPSS, 2026-11-04). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Authorization vulnerability in Apache ActiveMQ. An authenticated low-privilege Web Console user by default can access /admin/* paths in the Web Console. The default Jetty settings incorrectly did not limit those paths to only admins. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record BIT-activemq-2026-49877
- Revision 2 · amended ·
Amended from osv record GHSA-f892-4h9f-j7g9
- Revision 1 · created ·
Published from ghsa record GHSA-f892-4h9f-j7g9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-49877 Advisory: Apache ActiveMQ Improper Authorization vulnerability IDs: CVE-2026-49877, GHSA-f892-4h9f-j7g9 Record: https://patchnext.com/advisories/cve-2026-49877 (revision 3, source checked 5 Nov 2026, 06:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.activemq:apache-activemq 6.2.7, 5.19.8; activemq 6.2.7, 5.19.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.activemq:apache-activemq: affected < 5.19.8; >= 6.0.0, < 6.2.7; fixed in 5.19.8, 6.2.7 - Bitnami activemq: affected < 5.19.8; >= 6.0.0, < 6.2.7; fixed in 5.19.8, 6.2.7 ## Suggested inspection (read-only) - Maven org.apache.activemq:apache-activemq: check the installed version with your package manager. - Bitnami activemq: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.activemq:apache-activemq, activemq. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f892-4h9f-j7g9 (GitHub-reviewed advisory GHSA-f892-4h9f-j7g9 lists affected ranges: Maven org.apache.activemq:apache-activemq >=0 =6.0.0 <6.2.7) - Verified: https://osv.dev/vulnerability/BIT-activemq-2026-49877 (OSV record BIT-activemq-2026-49877 lists affected ranges: Bitnami activemq >=0 =6.0.0 <6.2.7 (fixed)) - Verified: https://osv.dev/vulnerability/GHSA-f892-4h9f-j7g9 (OSV record GHSA-f892-4h9f-j7g9 lists affected ranges: Maven org.apache.activemq:apache-activemq >=0 =6.0.0 <6.2.7 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…