Skip to content

← Actionable
Medium, CVSS 5.3

Kimai has Server-Side Request Forgery in Invoice PDF Rendering via Markdown Image URLs

CVE-2026-49865GHSA-pj8j-p4g4-4vw8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (kimai/kimai 2.58.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N · score source
EPSS
  • CVE-2026-49865: 0.35% estimated exploitation activity in the next 30 days; percentile 28.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Kimai 2.56.0 contains a server-side request forgery vulnerability in its invoice PDF preview and generation workflow. If an attacker can control Markdown content that is later rendered into an invoice PDF, such as Customer.invoiceText, the server-side PDF renderer will fetch remote image URLs embedded in Markdown image syntax. This allows the application server to issue outbound requests to attacker-controlled or internal targets during PDF rendering. The behavior can be used for internal network probing, server-side reachability checks, and potentially follow-on exploitation depending on deployment environment and accessible internal services. Details The vulnerable behavior occurs in the invoice rendering chain when user-controlled Markdown is transformed into HTML and then rendered by mPDF. - First, customer invoice text is copied into the invoice model. . Second, the default PDF invoice template renders that field through the Markdown-to-HTML filter. - Third, md2html…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pj8j-p4g4-4vw8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49865

Advisory: Kimai has Server-Side Request Forgery in Invoice PDF Rendering via Markdown Image URLs
IDs: CVE-2026-49865, GHSA-pj8j-p4g4-4vw8
Record: https://patchnext.com/advisories/cve-2026-49865 (revision 1, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: kimai/kimai 2.58.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist kimai/kimai: affected <= 2.57.0; fixed in 2.58.0

## Suggested inspection (read-only)
- Packagist kimai/kimai: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on kimai/kimai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pj8j-p4g4-4vw8 (GitHub-reviewed advisory GHSA-pj8j-p4g4-4vw8 lists affected ranges: Packagist kimai/kimai >=0 <=2.57.0)

Commands are suggestions: review each one before running it.

Loading voting…