Skip to content

← Actionable
Medium, CVSS 5.9

API Platform Core vulnerable to cross-user attribute leak in JSON:API and HAL item normalizers due to missing isCacheKeySafe gate

CVE-2026-49858GHSA-pjhx-3c3w-9v23

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (api-platform/core 4.3.8, 4.2.25, 4.1.29; api-platform/json-api 4.3.8, 4.2.25, 4.1.29; api-platform/hal 4.3.8, 4.2.25, 4.1.29), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist api-platform/core

    Affected
    >= 2.6.0, < 4.1.29>= 4.2.0, < 4.2.25>= 4.3.0, < 4.3.8
    Fixed in
    4.2.25, 4.3.8, 4.1.29
  • Packagist api-platform/json-api

    Affected
    >= 4.0.0, < 4.1.29>= 4.2.0, < 4.2.25>= 4.3.0, < 4.3.8
    Fixed in
    4.2.25, 4.3.8, 4.1.29
  • Packagist api-platform/hal

    Affected
    >= 4.0.0, < 4.1.29>= 4.2.0, < 4.2.25>= 4.3.0, < 4.3.8
    Fixed in
    4.2.25, 4.3.8, 4.1.29

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-pjhx-3c3w-9v23 lists affected ranges: Packagist api-platform/core >=2.6.0 =4.2.0 =4.3.0 =4.0.0 =4.2.0 =4.3.0 =4.0.0 =4.2.0 =4.3.0 <4.3.8

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-49858: 0.32% estimated exploitation activity in the next 30 days; percentile 24.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact #[ApiProperty(security: ...)] is evaluated per request to decide whether a property is exposed. The componentsCache arrays in ApiPlatform\JsonApi\Serializer\ItemNormalizer and ApiPlatform\Hal\Serializer\ItemNormalizer are keyed on $context['cachekey'], which is set unconditionally before delegating to the parent normalizer. The component structure (attributes, relationships, links) computed for one request can therefore be reused for a subsequent request whose user has a different set of accessible properties. A user with lower privileges may end up seeing the structure of properties that the security predicate would otherwise have hidden for them. This is the same vulnerability class as GHSA-428q-q3vv-3fq3 / CVE-2025-31485, which fixed only the GraphQL ItemNormalizer. The JSON:API and HAL paths were not addressed at the time. Exploitation conditions Exploitation requires all of the following to coincide: - The application exposes a resource via the JSON:API and/or HAL…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pjhx-3c3w-9v23

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49858

Advisory: API Platform Core vulnerable to cross-user attribute leak in JSON:API and HAL item normalizers due to missing isCacheKeySafe gate
IDs: CVE-2026-49858, GHSA-pjhx-3c3w-9v23
Record: https://patchnext.com/advisories/cve-2026-49858 (revision 1, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: api-platform/core 4.3.8, 4.2.25, 4.1.29; api-platform/json-api 4.3.8, 4.2.25, 4.1.29; api-platform/hal 4.3.8, 4.2.25, 4.1.29. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist api-platform/core: affected >= 2.6.0, < 4.1.29; >= 4.2.0, < 4.2.25; >= 4.3.0, < 4.3.8; fixed in 4.2.25, 4.3.8, 4.1.29
- Packagist api-platform/json-api: affected >= 4.0.0, < 4.1.29; >= 4.2.0, < 4.2.25; >= 4.3.0, < 4.3.8; fixed in 4.2.25, 4.3.8, 4.1.29
- Packagist api-platform/hal: affected >= 4.0.0, < 4.1.29; >= 4.2.0, < 4.2.25; >= 4.3.0, < 4.3.8; fixed in 4.2.25, 4.3.8, 4.1.29

## Suggested inspection (read-only)
- Packagist api-platform/core: check the installed version with your package manager.
- Packagist api-platform/json-api: check the installed version with your package manager.
- Packagist api-platform/hal: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on api-platform/core, api-platform/json-api, api-platform/hal.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pjhx-3c3w-9v23 (GitHub-reviewed advisory GHSA-pjhx-3c3w-9v23 lists affected ranges: Packagist api-platform/core >=2.6.0 =4.2.0 =4.3.0 =4.0.0 =4.2.0 =4.3.0 =4.0.0 =4.2.0 =4.3.0 <4.3.8)

Commands are suggestions: review each one before running it.

Loading voting…