tornado AsyncHTTPClient accumulates decompressed chunks without size limit (gzip bomb)
CVE-2026-49855GHSA-mgf9-4vpg-hj56
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tornado 6.5.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI tornado
- Affected
- < 6.5.6
- Fixed in
- 6.5.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mgf9-4vpg-hj56 lists affected ranges: PyPI tornado >=0 <6.5.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mgf9-4vpg-hj56 lists affected ranges: PyPI tornado >=0 <6.5.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-49855: 0.57% estimated exploitation activity in the next 30 days; percentile 47.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Tornado's gzip decompression routines work in limited-size chunks, but have no overall limit for the total size of decompressed chunks that they will accumulate (There has always been a limit for the total compressed size). This allows a malicious server to consume effectively unlimited amounts of memory if it is accessed via SimpleAsyncHTTPClient in its default configuration. HTTPServer is not affected in its default configuration, but it is if decompressrequest=True is set. This bug is fixed in Tornado 6.5.6. maxbodysize is now checked both for the compressed and cumulative decompressed size of the response. Prior to upgrading, this issue can be mitigated by setting decompressresponse=False or using CurlAsyncHTTPClient.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mgf9-4vpg-hj56
- Revision 1 · created ·
Published from osv record GHSA-mgf9-4vpg-hj56
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-49855 Advisory: tornado AsyncHTTPClient accumulates decompressed chunks without size limit (gzip bomb) IDs: CVE-2026-49855, GHSA-mgf9-4vpg-hj56 Record: https://patchnext.com/advisories/cve-2026-49855 (revision 2, source checked 26 Oct 2026, 13:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tornado 6.5.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI tornado: affected < 6.5.6; fixed in 6.5.6 ## Suggested inspection (read-only) - `python -m pip show tornado`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tornado. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mgf9-4vpg-hj56 (OSV record GHSA-mgf9-4vpg-hj56 lists affected ranges: PyPI tornado >=0 <6.5.6 (fixed)) - Verified: https://github.com/advisories/GHSA-mgf9-4vpg-hj56 (GitHub-reviewed advisory GHSA-mgf9-4vpg-hj56 lists affected ranges: PyPI tornado >=0 <6.5.6) Commands are suggestions: review each one before running it.
Loading voting…