Skip to content

← Actionable
Low, CVSS 3.7amended

Tornado has out-of-bounds memory access via C extension

CVE-2026-49854GHSA-cx3h-4qpv-8hc9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tornado 6.5.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tornado

    Affected
    < 6.5.6
    Fixed in
    6.5.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-49854: 0.42% estimated exploitation activity in the next 30 days; percentile 36.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Tornado's optional native extension tornado.speedups implements websocketmask without validating that the mask argument is exactly four bytes long. The C function reads four bytes from mask unconditionally, even when Python passes a shorter byte string. This can read beyond the provided buffer, exposing up to 3 bytes of uninitialized memory. The behavior is reachable from Tornado's XSRF token decoder when xsrfcookies=True and the native extension is active. Mitigations This bug is fixed in Tornado 6.5.6. Prior to upgrading to this version, setting the environment variable TORNADOEXTENSION=0 will disable the vulnerable code (at the expense of reducing websocket performance).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cx3h-4qpv-8hc9

  2. Revision 1 · created ·

    Published from osv record GHSA-cx3h-4qpv-8hc9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49854

Advisory: Tornado has out-of-bounds memory access via C extension
IDs: CVE-2026-49854, GHSA-cx3h-4qpv-8hc9
Record: https://patchnext.com/advisories/cve-2026-49854 (revision 2, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tornado 6.5.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tornado: affected < 6.5.6; fixed in 6.5.6

## Suggested inspection (read-only)
- `python -m pip show tornado`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tornado.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cx3h-4qpv-8hc9 (OSV record GHSA-cx3h-4qpv-8hc9 lists affected ranges: PyPI tornado >=0 <6.5.6 (fixed))
- Verified: https://github.com/advisories/GHSA-cx3h-4qpv-8hc9 (GitHub-reviewed advisory GHSA-cx3h-4qpv-8hc9 lists affected ranges: PyPI tornado >=0 <6.5.6)

Commands are suggestions: review each one before running it.

Loading voting…