Skip to content

← Actionable
Medium, CVSS 5.9

GoBGP: BGP OPEN capability parser may read capability values outside declared CapLen boundaries

CVE-2026-49837GHSA-gjrg-jjr3-56cm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/osrg/gobgp/v4 4.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-49837: 0.33% estimated exploitation activity in the next 30 days; percentile 26.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary GoBGP contains a BGP OPEN capability parsing issue where several concrete capability decoders may parse data from the full remaining capability buffer instead of the slice bounded by the declared capability length, CapLen. A malformed BGP OPEN message can cause bytes from a following capability to be interpreted as part of the current capability. The most security-relevant case is the 4-octet AS capability, where a capability with CapLen == 0 may cause the parser to read bytes from the following capability as the 4-octet AS value. This parsed value may later affect peer AS validation during BGP session establishment. Details The issue is in the BGP OPEN capability parser under: - pkg/packet/bgp/bgp.go - pkg/packet/bgp/validate.go - The BGP OPEN optional parameter capability format includes a capability code, a capability length field, and a capability value. Each concrete capability decoder should only parse bytes inside the declared capability value boundary. In affected…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gjrg-jjr3-56cm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49837

Advisory: GoBGP: BGP OPEN capability parser may read capability values outside declared CapLen boundaries
IDs: CVE-2026-49837, GHSA-gjrg-jjr3-56cm
Record: https://patchnext.com/advisories/cve-2026-49837 (revision 1, source checked 26 Oct 2026, 15:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/osrg/gobgp/v4 4.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/osrg/gobgp/v4: affected <= 4.5.0; fixed in 4.6.0

## Suggested inspection (read-only)
- Go github.com/osrg/gobgp/v4: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/osrg/gobgp/v4.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gjrg-jjr3-56cm (GitHub-reviewed advisory GHSA-gjrg-jjr3-56cm lists affected ranges: Go github.com/osrg/gobgp/v4 >=0 <=4.5.0)

Commands are suggestions: review each one before running it.

Loading voting…