Skip to content

← Actionable
Medium, CVSS 4.6amended

psd-tools vulnerable to arbitrary file write via smart-object filename

CVE-2026-49836GHSA-2rmg-vrx8-9j2f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (psd-tools 1.17.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI psd-tools

    Affected
    <= 1.17.0
    Fixed in
    1.17.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.6 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-49836: 0.19% estimated exploitation activity in the next 30 days; percentile 8.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

psd-tools: arbitrary file write/read via smart-object path traversal Summary In psd-tools (all releases exposing the SmartObject API through v1.17.0), SmartObject.save() writes an embedded smart object to a path taken verbatim from the PSD file. Because that name is attacker-controlled and unsanitised, a tool that extracts embedded objects from an untrusted .psd can be made to write attacker-chosen bytes to an attacker-chosen path (absolute or ../-traversing), outside its intended output directory. A secondary issue in SmartObject.open() for external-kind smart objects allows the attacker-controlled fullPath descriptor to be used as an arbitrary file read path, enabling exfiltration of the read content to the controlled write destination. Both issues are fixed in v1.17.1. Details Write path — SmartObject.save() (primary) src/psdtools/api/smartobject.py:170-179 (tag v1.17.0): self.filename comes from the file with no validation — the filename property (:62-67) returns…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2rmg-vrx8-9j2f

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-2rmg-vrx8-9j2f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49836

Advisory: psd-tools vulnerable to arbitrary file write via smart-object filename
IDs: CVE-2026-49836, GHSA-2rmg-vrx8-9j2f
Record: https://patchnext.com/advisories/cve-2026-49836 (revision 3, source checked 26 Oct 2026, 13:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: psd-tools 1.17.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI psd-tools: affected <= 1.17.0; fixed in 1.17.1

## Suggested inspection (read-only)
- `python -m pip show psd-tools`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on psd-tools.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2rmg-vrx8-9j2f (OSV record GHSA-2rmg-vrx8-9j2f lists affected ranges: PyPI psd-tools >=0 <1.17.1 (fixed))
- Verified: https://github.com/advisories/GHSA-2rmg-vrx8-9j2f (GitHub-reviewed advisory GHSA-2rmg-vrx8-9j2f lists affected ranges: PyPI psd-tools >=0 <=1.17.0)

Commands are suggestions: review each one before running it.

Loading voting…