Skip to content

← Actionable
Medium, CVSS 5.9

sigstore-go has a multi-log threshold bypass via single compromised log

CVE-2026-49834GHSA-9vcr-p3rj-q5q6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/sigstore/sigstore-go 1.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-49834: 0.18% estimated exploitation activity in the next 30 days; percentile 7.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Who is impacted? A verifier configured with WithTransparencyLog(N1) or WithSignedCertificateTimestamps(N1) expected defense-in-depth against the compromise of a single log instance. However, threshold counting counted verified witnesses per-entry or per-validation-path rather than per-log-authority. As a result, a single compromised transparency log could forge multiple entries with different indices, and a single compromised CT log could verify multiple times (either across multiple certificate chains or via multiple embedded SCTs), fully satisfying the multi-log threshold requirements and defeating the multi-log policy. Note that this does not affect Cosign, as Cosign sets a threshold of 1. Patches Has the problem been patched? What versions should users upgrade to? Upgrade to v1.1.5. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? There is no workaround, beyond relying on trusted logs.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9vcr-p3rj-q5q6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49834

Advisory: sigstore-go has a multi-log threshold bypass via single compromised log
IDs: CVE-2026-49834, GHSA-9vcr-p3rj-q5q6
Record: https://patchnext.com/advisories/cve-2026-49834 (revision 1, source checked 26 Oct 2026, 15:28 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/sigstore/sigstore-go 1.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/sigstore/sigstore-go: affected <= 1.1.4; fixed in 1.2.0

## Suggested inspection (read-only)
- Go github.com/sigstore/sigstore-go: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/sigstore/sigstore-go.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9vcr-p3rj-q5q6 (GitHub-reviewed advisory GHSA-9vcr-p3rj-q5q6 lists affected ranges: Go github.com/sigstore/sigstore-go >=0 <=1.1.4)

Commands are suggestions: review each one before running it.

Loading voting…