DSpace has possible Remote Code Execution (RCE) through Velocity Templates used by LDN
CVE-2026-49832GHSA-9x82-rm84-c6x7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.dspace:dspace-api 10.0, 9.3, 8.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.dspace:dspace-api
- Affected
- >= 8.0-rc1, < 8.4>= 9.0-rc1, < 9.3>= 10.0-rc1, <= 10.0-rc1
- Fixed in
- 10.0, 9.3, 8.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9x82-rm84-c6x7 lists affected ranges: Maven org.dspace:dspace-api >=8.0-rc1 =9.0-rc1 =10.0-rc1 <=10.0-rc1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.0 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-49832: 0.87% estimated exploitation activity in the next 30 days; percentile 58.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Overview Remote Code Execution (RCE) is possible via Velocity Templates used by DSpace for COAR Notify/LDN messages. This vulnerability impacts DSpace versions 8.0 <= 8.3, 9.0 <= 9.2. The attacker MUST already have DSpace administrator credentials in order to perform the attack. This attack is related to the path traversal attack identified in GHSA-9qm4-rh6w-pq5x as it was the impactful part of the "proof-of-concept" attack chain. Impact When chained with the LDN Path Traversal Attack identified in GHSA-9qm4-rh6w-pq5x, it may be possible to execute Java directly from Velocity templates using reflection. This is a very high impact vulnerability, but the attack can only be performed by a user that has DSpace Administrator privileges. Disabling LDN (see below) removes all known attack paths. Velocity is also used for email templating, but there is no known attack path via emails templates. Nonetheless, the patches below also apply to email templates. Patches The fix is included in…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9x82-rm84-c6x7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-49832 Advisory: DSpace has possible Remote Code Execution (RCE) through Velocity Templates used by LDN IDs: CVE-2026-49832, GHSA-9x82-rm84-c6x7 Record: https://patchnext.com/advisories/cve-2026-49832 (revision 1, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.dspace:dspace-api 10.0, 9.3, 8.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.dspace:dspace-api: affected >= 8.0-rc1, < 8.4; >= 9.0-rc1, < 9.3; >= 10.0-rc1, <= 10.0-rc1; fixed in 10.0, 9.3, 8.4 ## Suggested inspection (read-only) - Maven org.dspace:dspace-api: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.dspace:dspace-api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9x82-rm84-c6x7 (GitHub-reviewed advisory GHSA-9x82-rm84-c6x7 lists affected ranges: Maven org.dspace:dspace-api >=8.0-rc1 =9.0-rc1 =10.0-rc1 <=10.0-rc1) Commands are suggestions: review each one before running it.
Loading voting…